summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKarl Linden <karl.j.linden@gmail.com>2017-12-05 13:44:44 +0100
committerPatrice Clement <monsieurp@gentoo.org>2017-12-20 23:38:29 +0100
commitd503828cfe88f7cd3ce262cc40f0db31316f46b2 (patch)
tree262399316a2bd92727ad3b68b301840f7295b592 /media-sound/patchage
parentmedia-sound/patchage: bump to EAPI 6. (diff)
downloadgentoo-d503828cfe88f7cd3ce262cc40f0db31316f46b2.tar.gz
gentoo-d503828cfe88f7cd3ce262cc40f0db31316f46b2.tar.bz2
gentoo-d503828cfe88f7cd3ce262cc40f0db31316f46b2.zip
media-sound/patchage: update icons cache.
This fixes QA warnings about missing calls to gnome2_icon_cache_update. Package-Manager: Portage-2.3.16, Repoman-2.3.6
Diffstat (limited to 'media-sound/patchage')
-rw-r--r--media-sound/patchage/patchage-0.5.0-r2.ebuild10
-rw-r--r--media-sound/patchage/patchage-1.0.0-r1.ebuild10
2 files changed, 18 insertions, 2 deletions
diff --git a/media-sound/patchage/patchage-0.5.0-r2.ebuild b/media-sound/patchage/patchage-0.5.0-r2.ebuild
index ecd4516090e6..98b3a269c3f9 100644
--- a/media-sound/patchage/patchage-0.5.0-r2.ebuild
+++ b/media-sound/patchage/patchage-0.5.0-r2.ebuild
@@ -5,7 +5,7 @@ EAPI=6
PYTHON_COMPAT=( python2_7 )
PYTHON_REQ_USE='threads(+)'
-inherit flag-o-matic waf-utils python-any-r1
+inherit flag-o-matic gnome2-utils waf-utils python-any-r1
DESCRIPTION="Modular patch bay for audio and MIDI systems"
HOMEPAGE="http://wiki.drobilla.net/Patchage"
@@ -43,3 +43,11 @@ src_configure() {
$(use alsa || echo "--no-alsa") \
$(use lash || echo "--no-lash")
}
+
+pkg_postinst() {
+ gnome2_icon_cache_update
+}
+
+pkg_postrm() {
+ gnome2_icon_cache_update
+}
diff --git a/media-sound/patchage/patchage-1.0.0-r1.ebuild b/media-sound/patchage/patchage-1.0.0-r1.ebuild
index 98c7403ade26..6fe9924872d5 100644
--- a/media-sound/patchage/patchage-1.0.0-r1.ebuild
+++ b/media-sound/patchage/patchage-1.0.0-r1.ebuild
@@ -4,7 +4,7 @@
EAPI=6
PYTHON_COMPAT=( python2_7 )
PYTHON_REQ_USE='threads(+)'
-inherit waf-utils python-any-r1
+inherit gnome2-utils waf-utils python-any-r1
DESCRIPTION="Modular patch bay for JACK-based audio and MIDI systems"
HOMEPAGE="http://drobilla.net/software/patchage"
@@ -38,3 +38,11 @@ src_configure() {
$(use jack-dbus && echo "--jack-dbus") \
$(use session && echo "--jack-session-manage")
}
+
+pkg_postinst() {
+ gnome2_icon_cache_update
+}
+
+pkg_postrm() {
+ gnome2_icon_cache_update
+}