summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'media-sound/pms/pms-0.42.ebuild')
-rw-r--r--media-sound/pms/pms-0.42.ebuild45
1 files changed, 45 insertions, 0 deletions
diff --git a/media-sound/pms/pms-0.42.ebuild b/media-sound/pms/pms-0.42.ebuild
new file mode 100644
index 000000000000..a6d0e145873b
--- /dev/null
+++ b/media-sound/pms/pms-0.42.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=2
+
+inherit autotools
+
+DESCRIPTION="Practical Music Search: an open source ncurses client for mpd, written in C++"
+HOMEPAGE="http://pms.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.bz2"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="regex"
+
+RDEPEND="
+ sys-libs/ncurses
+ dev-libs/glib:2
+ regex? ( >=dev-libs/boost-1.36 )
+"
+DEPEND="
+ virtual/pkgconfig
+ ${RDEPEND}
+"
+
+src_prepare() {
+ # bug #424717
+ sed -i "s:^CXXFLAGS +=:AM_CXXFLAGS =:g" Makefile.am || die "sed failed"
+
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ $(use_enable regex) ||
+ die "configure failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "installation failed"
+
+ dodoc AUTHORS README TODO
+}