summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'media-sound/pms/pms-9999.ebuild')
-rw-r--r--media-sound/pms/pms-9999.ebuild35
1 files changed, 7 insertions, 28 deletions
diff --git a/media-sound/pms/pms-9999.ebuild b/media-sound/pms/pms-9999.ebuild
index c4873bce0ccb..6d7622c10d99 100644
--- a/media-sound/pms/pms-9999.ebuild
+++ b/media-sound/pms/pms-9999.ebuild
@@ -3,7 +3,7 @@
EAPI=6
-inherit autotools flag-o-matic git-r3 toolchain-funcs versionator
+inherit cmake-utils git-r3
DESCRIPTION="Practical Music Search: an open source ncurses client for mpd, written in C++"
HOMEPAGE="https://ambientsound.github.io/pms"
@@ -12,45 +12,24 @@ EGIT_REPO_URI="https://github.com/ambientsound/pms.git"
LICENSE="GPL-3+"
SLOT="0"
KEYWORDS=""
-IUSE="regex doc"
+IUSE="+regex doc"
RDEPEND="
sys-libs/ncurses:0=[unicode]
dev-libs/glib:2
media-libs/libmpdclient
- virtual/libintl
"
DEPEND="
virtual/pkgconfig
- dev-util/intltool
- sys-devel/gettext
doc? ( app-text/pandoc )
${RDEPEND}
"
-DOCS=( AUTHORS README TODO )
-
-pkg_pretend() {
- if [[ ${MERGE_TYPE} != binary ]] && use regex; then
- if tc-is-gcc && ! version_is_at_least 4.9 $(gcc-version); then
- die "Clang or GCC >= 4.9 is required for proper regex support"
- fi
- fi
-}
-
-src_prepare() {
- eapply "${FILESDIR}/pms-9999-fix-automagic-dep.patch"
- eapply_user
-
- eautoreconf
-}
-
src_configure() {
- # Required for ncurses[tinfo]
- append-cppflags $($(tc-getPKG_CONFIG) --cflags ncursesw)
- append-libs $($(tc-getPKG_CONFIG) --libs ncursesw)
+ local mycmakeargs=(
+ -DENABLE_DOC=$(usex doc)
+ -DENABLE_REGEX=$(usex regex)
+ )
- econf \
- $(use_enable regex) \
- $(use_with doc)
+ cmake-utils_src_configure
}