summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'media-sound/pnmixer/pnmixer-9999.ebuild')
-rw-r--r--media-sound/pnmixer/pnmixer-9999.ebuild57
1 files changed, 57 insertions, 0 deletions
diff --git a/media-sound/pnmixer/pnmixer-9999.ebuild b/media-sound/pnmixer/pnmixer-9999.ebuild
new file mode 100644
index 000000000000..d97a17c9c003
--- /dev/null
+++ b/media-sound/pnmixer/pnmixer-9999.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+WANT_LIBTOOL=none
+inherit autotools eutils gnome2-utils git-2
+
+DESCRIPTION="Volume mixer for the system tray"
+HOMEPAGE="https://github.com/nicklan/pnmixer"
+EGIT_REPO_URI="git@github.com:nicklan/pnmixer.git
+ https://github.com/nicklan/pnmixer.git"
+EGIT_BRANCH="master"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS=""
+IUSE="debug libnotify"
+
+RDEPEND="dev-libs/glib:2
+ media-libs/alsa-lib
+ >=x11-libs/gtk+-3.6:3
+ x11-libs/libX11
+ libnotify? ( x11-libs/libnotify )"
+DEPEND="${RDEPEND}
+ sys-devel/gettext
+ virtual/pkgconfig"
+
+src_prepare() {
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ $(use_with libnotify) \
+ $(use_enable debug) \
+ --enable-minimal-flags \
+ --with-gtk3
+}
+
+src_install() {
+ default
+ newicon -s 128 pixmaps/${PN}-about.png ${PN}.png
+}
+
+pkg_preinst() {
+ gnome2_icon_savelist
+}
+
+pkg_postinst() {
+ gnome2_icon_cache_update
+}
+
+pkg_postrm() {
+ gnome2_icon_cache_update
+}