summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'media-sound/pulseaudio-ctl/pulseaudio-ctl-1.70-r1.ebuild')
-rw-r--r--media-sound/pulseaudio-ctl/pulseaudio-ctl-1.70-r1.ebuild21
1 files changed, 21 insertions, 0 deletions
diff --git a/media-sound/pulseaudio-ctl/pulseaudio-ctl-1.70-r1.ebuild b/media-sound/pulseaudio-ctl/pulseaudio-ctl-1.70-r1.ebuild
new file mode 100644
index 000000000000..f6150651fbb2
--- /dev/null
+++ b/media-sound/pulseaudio-ctl/pulseaudio-ctl-1.70-r1.ebuild
@@ -0,0 +1,21 @@
+# Copyright 2019-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="CLI utility to control PulseAudio volume"
+HOMEPAGE="https://github.com/graysky2/pulseaudio-ctl"
+SRC_URI="https://github.com/graysky2/pulseaudio-ctl/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~riscv ~x86"
+IUSE=""
+
+# Optional runtime deps: dbus-send for KDE OSD, notify-send for libnotify
+# in both cases they should be already present if DE supports them
+RDEPEND="|| ( media-sound/pulseaudio-daemon media-sound/pulseaudio[daemon(+)] )"
+
+src_install() {
+ emake install PREFIX="${EPREFIX}/usr" DESTDIR="${D}"
+}