summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'media-sound/pulseaudio/files/pulseaudio-14.99.2-require-GIO-for-RTP-GStreamer.patch')
-rw-r--r--media-sound/pulseaudio/files/pulseaudio-14.99.2-require-GIO-for-RTP-GStreamer.patch36
1 files changed, 36 insertions, 0 deletions
diff --git a/media-sound/pulseaudio/files/pulseaudio-14.99.2-require-GIO-for-RTP-GStreamer.patch b/media-sound/pulseaudio/files/pulseaudio-14.99.2-require-GIO-for-RTP-GStreamer.patch
new file mode 100644
index 000000000000..dfce24881566
--- /dev/null
+++ b/media-sound/pulseaudio/files/pulseaudio-14.99.2-require-GIO-for-RTP-GStreamer.patch
@@ -0,0 +1,36 @@
+From fe25df45d5742f20a225e9d9cd790156a7f05943 Mon Sep 17 00:00:00 2001
+From: "Igor V. Kovalenko" <igor.v.kovalenko@gmail.com>
+Date: Mon, 21 Jun 2021 02:32:41 +0300
+Subject: [PATCH] build-sys: meson: require GIO dependency for RTP-GStreamer
+
+---
+ meson.build | 6 ++++--
+ 1 file changed, 4 insertions(+), 2 deletions(-)
+
+diff --git a/meson.build b/meson.build
+index fdd8bf655..61660b981 100644
+--- a/meson.build
++++ b/meson.build
+@@ -614,8 +614,9 @@ if dbus_dep.found()
+ cdata.set('HAVE_DBUS', 1)
+ endif
+
+-gio_dep = dependency('gio-2.0', version : '>= 2.26.0', required : get_option('gsettings'))
+-if gio_dep.found()
++gio_dep = dependency('gio-2.0', version : '>= 2.26.0')
++if get_option('gsettings').enabled()
++ assert(gio_dep.found(), 'GSettings support needs glib I/O library (GIO)')
+ cdata.set('HAVE_GSETTINGS', 1)
+ endif
+
+@@ -760,6 +761,7 @@ gstrtp_dep = dependency('gstreamer-rtp-1.0', required : get_option('gstreamer'))
+
+ have_gstreamer = false
+ if gst_dep.found() and gstapp_dep.found() and gstrtp_dep.found()
++ assert(gio_dep.found(), 'GStreamer-based RTP needs glib I/O library (GIO)')
+ have_gstreamer = true
+ endif
+
+--
+GitLab
+