summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'media-sound/pulsemixer/pulsemixer-9999.ebuild')
-rw-r--r--media-sound/pulsemixer/pulsemixer-9999.ebuild25
1 files changed, 25 insertions, 0 deletions
diff --git a/media-sound/pulsemixer/pulsemixer-9999.ebuild b/media-sound/pulsemixer/pulsemixer-9999.ebuild
new file mode 100644
index 000000000000..45f1ee6b0c9b
--- /dev/null
+++ b/media-sound/pulsemixer/pulsemixer-9999.ebuild
@@ -0,0 +1,25 @@
+# Copyright 2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6,7,8} )
+PYTHON_REQ_USE="ncurses"
+
+inherit distutils-r1
+
+DESCRIPTION="CLI and curses mixer for PulseAudio"
+HOMEPAGE="https://github.com/GeorgeFilipkin/pulsemixer"
+
+if [[ ${PV} == *9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/GeorgeFilipkin/${PN}"
+else
+ SRC_URI="https://github.com/GeorgeFilipkin/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="MIT"
+SLOT="0"
+
+RDEPEND="media-sound/pulseaudio"