summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'media-sound/qsynth/qsynth-9999.ebuild')
-rw-r--r--media-sound/qsynth/qsynth-9999.ebuild49
1 files changed, 21 insertions, 28 deletions
diff --git a/media-sound/qsynth/qsynth-9999.ebuild b/media-sound/qsynth/qsynth-9999.ebuild
index 70d95bac46aa..496e8129a1ca 100644
--- a/media-sound/qsynth/qsynth-9999.ebuild
+++ b/media-sound/qsynth/qsynth-9999.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
-inherit cmake desktop qmake-utils xdg-utils
+inherit cmake desktop xdg
DESCRIPTION="Qt application to control FluidSynth"
HOMEPAGE="https://qsynth.sourceforge.io/"
@@ -12,39 +12,40 @@ if [[ ${PV} == *9999* ]]; then
EGIT_REPO_URI="https://git.code.sf.net/p/qsynth/code"
inherit git-r3
else
- SRC_URI="mirror://sourceforge/qsynth/${P}.tar.gz"
+ SRC_URI="https://downloads.sourceforge.net/qsynth/${P}.tar.gz"
KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
fi
LICENSE="GPL-2"
SLOT="0"
-IUSE="+alsa debug jack pulseaudio"
+IUSE="+alsa debug jack pulseaudio qt6"
REQUIRED_USE="|| ( alsa jack pulseaudio )"
BDEPEND="
- dev-qt/linguist-tools:5
+ qt6? ( dev-qt/qttools:6[linguist] )
+ !qt6? ( dev-qt/linguist-tools:5 )
"
DEPEND="
- dev-qt/qtcore:5
- dev-qt/qtgui:5
- dev-qt/qtnetwork:5
- dev-qt/qtwidgets:5
+ qt6? (
+ dev-qt/qtbase:6[gui,network,widgets]
+ dev-qt/qtsvg:6
+ )
+ !qt6? (
+ dev-qt/qtcore:5
+ dev-qt/qtgui:5
+ dev-qt/qtnetwork:5
+ dev-qt/qtsvg:5
+ dev-qt/qtwidgets:5
+ )
media-sound/fluidsynth:=[jack?,alsa?,pulseaudio?]
"
RDEPEND="${DEPEND}"
-PATCHES=( "${FILESDIR}/${P}-cmake-no-git-version.patch" )
-
-src_prepare() {
- cmake_src_prepare
-
- sed -e "/^find_package.*QT/s/Qt6 //" -i CMakeLists.txt || die
-}
-
src_configure() {
local mycmakeargs=(
-DCONFIG_DEBUG=$(usex debug 1 0)
+ -DCONFIG_QT6=$(usex qt6 1 0)
)
cmake_src_configure
}
@@ -54,7 +55,7 @@ src_install() {
# The desktop file is invalid, and we also change the command
# depending on useflags
- rm "${D}/usr/share/applications/qsynth.desktop" || die
+ rm "${D}/usr/share/applications/org.rncbc.qsynth.desktop" || die
local cmd
if use jack; then
@@ -67,13 +68,5 @@ src_install() {
cmd="qsynth -a oss"
fi
- make_desktop_entry "${cmd}" Qsynth qsynth
-}
-
-pkg_postinst() {
- xdg_icon_cache_update
-}
-
-pkg_postrm() {
- xdg_icon_cache_update
+ make_desktop_entry "${cmd}" Qsynth org.rncbc.qsynth
}