summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'media-sound/reaper-bin/files/libSwell-makefile-cflags.patch')
-rw-r--r--media-sound/reaper-bin/files/libSwell-makefile-cflags.patch32
1 files changed, 32 insertions, 0 deletions
diff --git a/media-sound/reaper-bin/files/libSwell-makefile-cflags.patch b/media-sound/reaper-bin/files/libSwell-makefile-cflags.patch
new file mode 100644
index 000000000000..0f5d094f1bd0
--- /dev/null
+++ b/media-sound/reaper-bin/files/libSwell-makefile-cflags.patch
@@ -0,0 +1,32 @@
+diff --git a/WDL/swell/Makefile b/WDL/swell/Makefile
+index 642930a1..7f613f14 100644
+--- a/WDL/swell/Makefile
++++ b/WDL/swell/Makefile
+@@ -17,7 +17,7 @@ PKG_CONFIG = pkg-config
+
+ COMPILER=GCC
+
+-CFLAGS = -pipe -fvisibility=hidden -fno-math-errno -fPIC -DPIC -Wall -Wshadow -Wno-unused-function -Wno-multichar -Wtype-limits -Wno-unused-value
++CFLAGS += -fvisibility=hidden -fno-math-errno -fPIC -DPIC -Wall -Wshadow -Wno-unused-function -Wno-multichar -Wtype-limits -Wno-unused-value -Wno-error=array-bounds
+
+ CFLAGS += -DSWELL_MAKING_DYLIB
+
+@@ -63,16 +63,9 @@ endif
+
+
+ ifdef DEBUG
+-CFLAGS += -O0 -g -D_DEBUG
++CFLAGS += -D_DEBUG
+ else
+-CFLAGS += -O2 -DNDEBUG
+- ifdef DEBUG_INFO
+- CFLAGS += -g
+- else
+- ifneq ($(COMPILER),CLANG)
+- CFLAGS += -s
+- endif
+- endif
++CFLAGS += -DNDEBUG
+ endif
+
+ LINKEXTRA = -lpthread -ldl