summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'media-sound/tempest_for_eliza')
-rw-r--r--media-sound/tempest_for_eliza/Manifest1
-rw-r--r--media-sound/tempest_for_eliza/metadata.xml5
-rw-r--r--media-sound/tempest_for_eliza/tempest_for_eliza-1.0.5-r1.ebuild38
3 files changed, 44 insertions, 0 deletions
diff --git a/media-sound/tempest_for_eliza/Manifest b/media-sound/tempest_for_eliza/Manifest
new file mode 100644
index 000000000000..dc4a22884334
--- /dev/null
+++ b/media-sound/tempest_for_eliza/Manifest
@@ -0,0 +1 @@
+DIST tempest_for_eliza-1.0.5.tar.gz 45046 SHA256 c10e40b62e65cfd3862c99b31e8996b6c48b8eeb727efb741db5da041c2c1420
diff --git a/media-sound/tempest_for_eliza/metadata.xml b/media-sound/tempest_for_eliza/metadata.xml
new file mode 100644
index 000000000000..ae573a60407f
--- /dev/null
+++ b/media-sound/tempest_for_eliza/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>sound</herd>
+</pkgmetadata>
diff --git a/media-sound/tempest_for_eliza/tempest_for_eliza-1.0.5-r1.ebuild b/media-sound/tempest_for_eliza/tempest_for_eliza-1.0.5-r1.ebuild
new file mode 100644
index 000000000000..7c8413323764
--- /dev/null
+++ b/media-sound/tempest_for_eliza/tempest_for_eliza-1.0.5-r1.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=2
+inherit toolchain-funcs
+
+DESCRIPTION="listen to music on the radio generated by images on your screen"
+HOMEPAGE="http://www.erikyyy.de/tempest/"
+SRC_URI="http://www.erikyyy.de/tempest/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ~ppc x86"
+IUSE=""
+
+RDEPEND="media-libs/libsdl"
+DEPEND="${RDEPEND}"
+
+src_configure() {
+ tc-export CXX
+ econf \
+ --enable-debug \
+ --enable-nowarnerror
+}
+
+src_compile() {
+ emake CXXFLAGS="${CXXFLAGS}" LDFLAGS="${LDFLAGS}" || die "emake failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+ dodoc AUTHORS ChangeLog README
+
+ rm songs/Makefile*
+ insinto /usr/share/${PN}
+ doins songs/* || die "doins failed"
+}