summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'media-sound/toolame/toolame-02l-r3.ebuild')
-rw-r--r--media-sound/toolame/toolame-02l-r3.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/media-sound/toolame/toolame-02l-r3.ebuild b/media-sound/toolame/toolame-02l-r3.ebuild
new file mode 100644
index 000000000000..49497728423e
--- /dev/null
+++ b/media-sound/toolame/toolame-02l-r3.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+inherit eutils flag-o-matic toolchain-funcs
+
+DESCRIPTION="tooLAME - an optimized mpeg 1/2 layer 2 audio encoder"
+HOMEPAGE="http://www.planckenergy.com"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tgz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="alpha amd64 hppa ia64 ppc ppc64 sparc x86 ~amd64-fbsd ~x86-fbsd"
+IUSE=""
+
+src_prepare() {
+ epatch \
+ "${FILESDIR}"/${P}-gentoo.diff \
+ "${FILESDIR}"/${P}-uint.patch \
+ "${FILESDIR}"/${P}-uint32_t.patch
+}
+
+src_compile() {
+ append-lfs-flags
+ tc-export CC
+ emake
+}
+
+src_install() {
+ dobin ${PN}
+ dodoc README HISTORY FUTURE html/* text/*
+}