summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'media-sound/twolame')
-rw-r--r--media-sound/twolame/Manifest1
-rw-r--r--media-sound/twolame/files/0.3.13-perl-tests.patch32
-rw-r--r--media-sound/twolame/twolame-0.3.13-r2.ebuild47
3 files changed, 0 insertions, 80 deletions
diff --git a/media-sound/twolame/Manifest b/media-sound/twolame/Manifest
index 1ae373c260eb..f866c4b3eebe 100644
--- a/media-sound/twolame/Manifest
+++ b/media-sound/twolame/Manifest
@@ -1,2 +1 @@
-DIST twolame-0.3.13.tar.gz 660415 BLAKE2B 741e91983546241b984ce95ef3b1c3b00ff2c1e84f496961749b13b932a1c3fdcd44a3fde3a24e44d9a3ff9e859e64780ad60949f827d986608c51c1afe44912 SHA512 241ae5faebf05cb919959bb0545cb89e9b71cfb07f92a7118d864499ea4f0065ddaa646ab1482ffbcbca427d52c2436764074bd67fd19a1eb9979987f23163f7
DIST twolame-0.4.0.tar.gz 890908 BLAKE2B f61a49aed06dcd2a60744dd758b480670f14f0eece0586b62a0b21fe2d9ff8280f8f7324b7daf88e85675c6200a1c68815ddd6bafa308b503a52df4552031bb1 SHA512 cc594bc8d2322922280f915a3c0aa52540cca0350d6498bc96f3f60fd6e53f951e775ea015a44bdb29ec883b46b31a0e5483f6a5c188b02e30008289273c7d03
diff --git a/media-sound/twolame/files/0.3.13-perl-tests.patch b/media-sound/twolame/files/0.3.13-perl-tests.patch
deleted file mode 100644
index 5ec5b6601770..000000000000
--- a/media-sound/twolame/files/0.3.13-perl-tests.patch
+++ /dev/null
@@ -1,32 +0,0 @@
-From 11a5ecb89de1e61b016f3d7f358b09a4e611f1ad Mon Sep 17 00:00:00 2001
-From: Kent Fredric <kentfredric@gmail.com>
-Date: Tue, 17 Jan 2017 12:18:10 +1300
-Subject: [PATCH] tests/test.pl: stat the right file
-
-stat(@_) is effectively stat scalar @_
-
-becasue "stat" has a signature of "$" which coerces arrays to
-scalars, which here, returns the length of the array.
-
-This is going to be number 1, instead of the desired argument,
- the filename.
----
- tests/test.pl | 2 +-
- 1 file changed, 1 insertion(+), 1 deletion(-)
-
-diff --git a/tests/test.pl b/tests/test.pl
-index 658eadf..5513d6e 100755
---- a/tests/test.pl
-+++ b/tests/test.pl
-@@ -185,7 +185,7 @@ sub input_filepath {
- }
-
- sub filesize {
-- return (stat(@_))[7];
-+ return (stat($_[0]))[7];
- }
-
- sub md5_file {
---
-2.11.0
-
diff --git a/media-sound/twolame/twolame-0.3.13-r2.ebuild b/media-sound/twolame/twolame-0.3.13-r2.ebuild
deleted file mode 100644
index a3d518460048..000000000000
--- a/media-sound/twolame/twolame-0.3.13-r2.ebuild
+++ /dev/null
@@ -1,47 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-inherit ltprune multilib-minimal
-
-DESCRIPTION="An optimised MPEG Audio Layer 2 (MP2) encoder"
-HOMEPAGE="https://www.twolame.org"
-SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~alpha amd64 arm arm64 ~hppa ~ia64 ~mips ppc ppc64 sparc x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~x86-solaris"
-IUSE="static-libs"
-
-RDEPEND=">=media-libs/libsndfile-1.0.25[${MULTILIB_USEDEP}]"
-DEPEND="${RDEPEND}
- virtual/pkgconfig"
-
-PATCHES=( "${FILESDIR}/${PV}-perl-tests.patch" )
-
-src_prepare() {
- sed -i -e '/CFLAGS/s:-O3::' configure || die
- # remove -Werror, bug 493940
- sed -i -e '/WARNING_CFLAGS/s:-Werror::' configure || die
-
- if [[ ${CHOST} == *solaris* ]]; then
- # libsndfile doesn't like -std=c99 on Solaris
- sed -i -e '/CFLAGS/s:-std=c99::' configure || die
- # configure isn't really bourne shell (comment 0) or dash (comment 6)
- # compatible, bug #388885
- export CONFIG_SHELL=${BASH}
- fi
-
- default
-}
-
-multilib_src_configure() {
- ECONF_SOURCE=${S} \
- econf $(use_enable static-libs static)
-}
-
-multilib_src_install_all() {
- default
- prune_libtool_files --all
-}