summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'media-sound/ventrilo-server-bin/ventrilo-server-bin-2.3.1.ebuild')
-rw-r--r--media-sound/ventrilo-server-bin/ventrilo-server-bin-2.3.1.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/media-sound/ventrilo-server-bin/ventrilo-server-bin-2.3.1.ebuild b/media-sound/ventrilo-server-bin/ventrilo-server-bin-2.3.1.ebuild
new file mode 100644
index 000000000000..e0318852043f
--- /dev/null
+++ b/media-sound/ventrilo-server-bin/ventrilo-server-bin-2.3.1.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+IUSE=""
+DESCRIPTION="The Ventrilo Voice Communication Server"
+HOMEPAGE="http://www.ventrilo.com/"
+SRC_URI="ventrilo_srv-${PV}-Linux-i386.tar.gz"
+
+LICENSE="ventrilo"
+SLOT="0"
+KEYWORDS="-* x86 amd64"
+RESTRICT="fetch"
+
+S=${WORKDIR}
+
+RDEPEND="sys-libs/glibc"
+DEPEND=""
+
+QA_PRESTRIPPED="opt/ventrilo-server/ventrilo_srv
+ opt/ventrilo-server/ventrilo_status"
+
+pkg_nofetch() {
+ einfo "Please visit http://www.ventrilo.com/download.php"
+ einfo "and download the Linux i386 - 32bit ${PV} server."
+ einfo "Just save it in ${DISTDIR} !"
+}
+
+src_install() {
+ exeinto /opt/ventrilo-server
+ doexe ventrilo_{srv,status}
+
+ newinitd "${FILESDIR}"/init.d.ventrilo ventrilo
+ newconfd "${FILESDIR}"/conf.d.ventrilo ventrilo
+
+ insinto /opt/ventrilo-server
+ doins ventrilo_srv.ini
+
+ dohtml ventrilo_srv.htm
+}