summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'media-sound')
-rw-r--r--media-sound/lilypond/Manifest1
-rw-r--r--media-sound/lilypond/lilypond-2.19.61.ebuild147
2 files changed, 148 insertions, 0 deletions
diff --git a/media-sound/lilypond/Manifest b/media-sound/lilypond/Manifest
index 13350ada9611..094fc45a361e 100644
--- a/media-sound/lilypond/Manifest
+++ b/media-sound/lilypond/Manifest
@@ -6,3 +6,4 @@ DIST lilypond-2.19.57.tar.gz 17182103 SHA256 be86019ae91cf78267081e96f35cf682931
DIST lilypond-2.19.58.tar.gz 17188063 SHA256 074ee50299c7791403c8354a3604a0f0b3d35b8440fc53726d181b17c7ba4a72 SHA512 e5117a02c0a18b335fc74aa864c8432fe8dcf91691ad592cae7991e1097063397b82bdfbab6b24439e0027ce946059f2169534d998e63f2230fcbbba0fcc8e91 WHIRLPOOL fe301dc4c357adba53cf5bc247d9ecfa8384d2d21d39fe6d735ada1c4a180907bf576763fe7eaeb1f1eab80833bdd25e27399a8fd3fb28148790cfa799fa5558
DIST lilypond-2.19.59.tar.gz 17159567 SHA256 168f1d18850e295c1d5db71cf7c84aaf33bc9c6901f91c8b48fec58836bb5c1c SHA512 b915667bf3e86c8ee4be0519e4d351cb7f5e38354a882607ef3547467f9a56fcffd9bbdf40bbd1381624d5e8803c23a42ac5cdc95707a874c064493da369257a WHIRLPOOL 49b481a91e58436cafd0684a5e6470e0186a823758271f47e7d5b29f61c4317ad87fe536987685b1295cb1124d3dafaaed2e4602bce62f7168093d894265ec48
DIST lilypond-2.19.60.tar.gz 17158191 SHA256 648b8b7c0d5987fc9f3b3387e0ac07d28b6860ad7314c1495c2a4401335b333f SHA512 852f1aadfa1dab959cd50ffe5a37a9cbf235ea1fde762ecb8185eab6ae308ebb63dce59157fc481f311f23107a47e88bf3b5bba45126b94096701c29eaac0ad0 WHIRLPOOL 2552fc97968cb24402d1aed1db2555bad7300b53101d564ed15fc4c1ade36293f99f26afcda7a07ac705a91f383b987037dc70aea6625b0c3286992f136377bc
+DIST lilypond-2.19.61.tar.gz 17154903 SHA256 fc42103824cbd9e5d230ded0f73c8ecffae14998b2ad2e136914f7eab1eecb0a SHA512 870d747f6d29644824e965f4a0ff37555afbf8d8013f01965f64d4b95ca6487d15468aee27fa44036ed2d35b00f8e9bc69c22a670ad97f04ae39a16d57ea83b9 WHIRLPOOL bc690e42b2b52a5b39dea956f83558e3adb72f8027a1acb2441cd104fd5d85f2860f2a9f0c76ec882a9404ed6cbfcecd3ee4aa60d3148e79405ca9487e4de26f
diff --git a/media-sound/lilypond/lilypond-2.19.61.ebuild b/media-sound/lilypond/lilypond-2.19.61.ebuild
new file mode 100644
index 000000000000..a9a57ba996f9
--- /dev/null
+++ b/media-sound/lilypond/lilypond-2.19.61.ebuild
@@ -0,0 +1,147 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python2_7 )
+
+[[ "${PV}" = "9999" ]] && inherit git-r3
+inherit elisp-common autotools python-single-r1 xdg-utils
+
+if [[ "${PV}" = "9999" ]]; then
+ EGIT_REPO_URI="git://git.sv.gnu.org/lilypond.git"
+else
+ SRC_URI="http://download.linuxaudio.org/lilypond/sources/v${PV:0:4}/${P}.tar.gz"
+ KEYWORDS="~alpha ~amd64 ~arm ~hppa ~x86"
+fi
+
+DESCRIPTION="GNU Music Typesetter"
+HOMEPAGE="http://lilypond.org/"
+
+LICENSE="GPL-3 FDL-1.3"
+SLOT="0"
+LANGS=" ca cs da de el eo es fi fr it ja nl ru sv tr uk vi zh_TW"
+IUSE="debug emacs guile2 profile vim-syntax ${LANGS// / linguas_}"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+RDEPEND=">=app-text/ghostscript-gpl-8.15
+ >=dev-scheme/guile-1.8.2:12[deprecated,regex]
+ media-fonts/tex-gyre
+ media-libs/fontconfig
+ media-libs/freetype:2
+ >=x11-libs/pango-1.12.3
+ emacs? ( virtual/emacs )
+ guile2? ( >=dev-scheme/guile-2:12 )
+ !guile2? (
+ >=dev-scheme/guile-1.8.2:12[deprecated,regex]
+ <dev-scheme/guile-2.0:12
+ )
+ ${PYTHON_DEPS}"
+DEPEND="${RDEPEND}
+ app-text/t1utils
+ dev-lang/perl
+ dev-libs/kpathsea
+ >=dev-texlive/texlive-metapost-2013
+ || (
+ >=app-text/texlive-core-2013
+ >=dev-tex/metapost-1.803
+ )
+ virtual/pkgconfig
+ media-gfx/fontforge[png]
+ >=sys-apps/texinfo-4.11
+ >=sys-devel/bison-2.0
+ sys-devel/flex
+ sys-devel/gettext
+ sys-devel/make"
+
+# Correct output data for tests isn't bundled with releases
+RESTRICT="test"
+
+DOCS=( DEDICATION HACKING README.txt ROADMAP )
+
+pkg_setup() {
+ # make sure >=metapost-1.803 is selected if it's installed, bug 498704
+ if [[ ${MERGE_TYPE} != binary ]] && has_version ">=dev-tex/metapost-1.803" ; then
+ if [[ $(readlink "${EROOT}"/usr/bin/mpost) =~ mpost-texlive-* ]] ; then
+ einfo "Updating metapost symlink"
+ eselect mpost update || die
+ fi
+ fi
+
+ python-single-r1_pkg_setup
+}
+
+src_prepare() {
+ default
+
+ if ! use vim-syntax ; then
+ sed -i 's/vim//' GNUmakefile.in || die
+ fi
+
+ # respect CFLAGS
+ sed -i 's/OPTIMIZE -g/OPTIMIZE/' aclocal.m4 || die
+
+ for lang in ${LANGS}; do
+ use linguas_${lang} || rm po/${lang}.po || die
+ done
+
+ # respect AR
+ sed -i "s/^AR=ar/AR=$(tc-getAR)/" stepmake/stepmake/library-vars.make || die
+
+ # remove bundled texinfo file (fixes bug #448560)
+ rm tex/texinfo.tex || die
+
+ eautoreconf
+
+ xdg_environment_reset #586592
+}
+
+src_configure() {
+ # documentation generation currently not supported since it requires a newer
+ # version of texi2html than is currently in the tree
+
+ local myeconfargs=(
+ --with-texgyre-dir=/usr/share/fonts/tex-gyre
+ --disable-documentation
+ --disable-optimising
+ --disable-pipe
+ $(use_enable debug debugging)
+ $(use_enable guile2)
+ $(use_enable profile profiling)
+ )
+
+ econf "${myeconfargs[@]}"
+}
+
+src_compile() {
+ default
+
+ if use emacs ; then
+ elisp-compile elisp/lilypond-{font-lock,indent,mode,what-beat}.el \
+ || die "elisp-compile failed"
+ fi
+}
+
+src_install () {
+ emake DESTDIR="${D}" vimdir=/usr/share/vim/vimfiles install
+
+ # remove elisp files since they are in the wrong directory
+ rm -r "${ED}"/usr/share/emacs || die
+
+ if use emacs ; then
+ elisp-install ${PN} elisp/*.{el,elc} elisp/out/*.el \
+ || die "elisp-install failed"
+ elisp-site-file-install "${FILESDIR}"/50${PN}-gentoo.el
+ fi
+
+ python_fix_shebang "${ED}"
+
+ einstalldocs
+}
+
+pkg_postinst() {
+ use emacs && elisp-site-regen
+}
+
+pkg_postrm() {
+ use emacs && elisp-site-regen
+}