summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'media-sound')
-rw-r--r--media-sound/jack2/files/jack2-1.9.11_rc1-gcc7.patch19
-rw-r--r--media-sound/jack2/jack2-1.9.11_rc1-r1.ebuild4
2 files changed, 23 insertions, 0 deletions
diff --git a/media-sound/jack2/files/jack2-1.9.11_rc1-gcc7.patch b/media-sound/jack2/files/jack2-1.9.11_rc1-gcc7.patch
new file mode 100644
index 000000000000..dcde5fb422f8
--- /dev/null
+++ b/media-sound/jack2/files/jack2-1.9.11_rc1-gcc7.patch
@@ -0,0 +1,19 @@
+commit f7bccdca651592cc4082b28fd4a01ed6ef8ab655
+Author: Kjetil Matheussen <k.s.matheussen@notam02.no>
+Date: Sat Jul 15 13:21:59 2017 +0200
+
+ Tests: Fix compilation with gcc7
+
+diff --git a/tests/test.cpp b/tests/test.cpp
+index 8a8a8117..d2ef9a05 100644
+--- a/tests/test.cpp
++++ b/tests/test.cpp
+@@ -479,7 +479,7 @@ int process4(jack_nframes_t nframes, void *arg)
+ jack_nframes_t delta_time = cur_time - last_time;
+
+ Log("calling process4 callback : jack_frame_time = %ld delta_time = %ld\n", cur_time, delta_time);
+- if (delta_time > 0 && (jack_nframes_t)abs(delta_time - cur_buffer_size) > tolerance) {
++ if (delta_time > 0 && abs((int64_t)delta_time - (int64_t)cur_buffer_size) > (int64_t)tolerance) {
+ printf("!!! ERROR !!! jack_frame_time seems to return incorrect values cur_buffer_size = %d, delta_time = %d tolerance %d\n", cur_buffer_size, delta_time, tolerance);
+ }
+
diff --git a/media-sound/jack2/jack2-1.9.11_rc1-r1.ebuild b/media-sound/jack2/jack2-1.9.11_rc1-r1.ebuild
index 0823bd254c5a..3b62bb738cce 100644
--- a/media-sound/jack2/jack2-1.9.11_rc1-r1.ebuild
+++ b/media-sound/jack2/jack2-1.9.11_rc1-r1.ebuild
@@ -49,6 +49,10 @@ RDEPEND="${CDEPEND}
DOCS=( ChangeLog README README_NETJACK2 TODO )
+PATCHES=(
+ "${FILESDIR}"/${P}-gcc7.patch
+)
+
src_prepare() {
default
multilib_copy_sources