summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'media-tv/tvheadend/tvheadend-4.0.9.ebuild')
-rw-r--r--media-tv/tvheadend/tvheadend-4.0.9.ebuild6
1 files changed, 3 insertions, 3 deletions
diff --git a/media-tv/tvheadend/tvheadend-4.0.9.ebuild b/media-tv/tvheadend/tvheadend-4.0.9.ebuild
index 939aac745cf8..fa2ad2738980 100644
--- a/media-tv/tvheadend/tvheadend-4.0.9.ebuild
+++ b/media-tv/tvheadend/tvheadend-4.0.9.ebuild
@@ -17,13 +17,12 @@ LICENSE="GPL-3"
SLOT="0"
KEYWORDS="~amd64 ~x86"
-IUSE="avahi capmt constcw +cwc dbus +dvb +dvbscan ffmpeg hdhomerun libav imagecache inotify iptv satip +timeshift uriparser xmltv zlib"
+IUSE="capmt constcw +cwc dbus +dvb +dvbscan ffmpeg hdhomerun libav imagecache inotify iptv satip +timeshift uriparser xmltv zeroconf zlib"
# does not build with ffmpeg-3 - bug 574990
# https://tvheadend.org/issues/3597
RDEPEND="dev-libs/openssl:=
virtual/libiconv
- avahi? ( net-dns/avahi )
dbus? ( sys-apps/dbus )
ffmpeg? (
!libav? ( <media-video/ffmpeg-3:= )
@@ -31,6 +30,7 @@ RDEPEND="dev-libs/openssl:=
)
hdhomerun? ( media-libs/libhdhomerun )
uriparser? ( dev-libs/uriparser )
+ zeroconf? ( net-dns/avahi )
zlib? ( sys-libs/zlib )"
DEPEND="${RDEPEND}
@@ -71,7 +71,6 @@ src_configure() {
--disable-ccache \
--nowerror \
--disable-hdhomerun_static \
- $(use_enable avahi) \
$(use_enable capmt) \
$(use_enable constcw) \
$(use_enable cwc) \
@@ -87,6 +86,7 @@ src_configure() {
$(use_enable satip satip_client) \
$(use_enable timeshift) \
$(use_enable uriparser) \
+ $(use_enable zeroconf avahi) \
$(use_enable zlib)
}