summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'media-video/aegisub/files/aegisub-3.2.2-respect-user-compiler-flags.patch')
-rw-r--r--media-video/aegisub/files/aegisub-3.2.2-respect-user-compiler-flags.patch30
1 files changed, 30 insertions, 0 deletions
diff --git a/media-video/aegisub/files/aegisub-3.2.2-respect-user-compiler-flags.patch b/media-video/aegisub/files/aegisub-3.2.2-respect-user-compiler-flags.patch
new file mode 100644
index 000000000000..caecf82a7ff6
--- /dev/null
+++ b/media-video/aegisub/files/aegisub-3.2.2-respect-user-compiler-flags.patch
@@ -0,0 +1,30 @@
+diff --git a/configure.ac b/configure.ac
+index be657b0..fca48e0 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -139,20 +139,17 @@ CC="$PTHREAD_CC"
+ AC_ARG_ENABLE(compiler-flags, AS_HELP_STRING([--disable-compiler-flags],[Disable *all* additional compiler flags. [no]]))
+
+ AS_IF([test x$enable_compiler_flags != xno], [
+- CFLAGS="$CFLAGS -Wall -Wextra -Wno-unused-parameter -std=gnu99 -pipe -g"
+- CXXFLAGS="$CXXFLAGS -Wall -Wextra -Wno-unused-parameter -fno-strict-aliasing -pipe -g"
++ CFLAGS="$CFLAGS -Wall -Wextra -Wno-unused-parameter"
++ CXXFLAGS="$CXXFLAGS -Wall -Wextra -Wno-unused-parameter"
++ AC_C_FLAG([-std=gnu99])
+ AC_CXX_FLAG([-std=c++11])
+- AC_CXX_FLAG([-Wno-c++11-narrowing])
+ AC_C_FLAG([-Wno-unused-local-typedefs])
+ AC_CXX_FLAG([-Wno-unused-local-typedefs])
+
+ # -O* messes with debugging.
+ AS_IF([test x$enable_debug = xyes], [
+- CFLAGS="$CFLAGS -O0"
+- CXXFLAGS="$CXXFLAGS -O0"
+- ], [
+- CFLAGS="$CFLAGS -O3"
+- CXXFLAGS="$CXXFLAGS -O3"
++ CFLAGS="$CFLAGS -O0 -g"
++ CXXFLAGS="$CXXFLAGS -O0 -g"
+ ])
+ ])
+