summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'media-video/bdsup2sub++/bdsup2sub++-1.0.2.ebuild')
-rw-r--r--media-video/bdsup2sub++/bdsup2sub++-1.0.2.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/media-video/bdsup2sub++/bdsup2sub++-1.0.2.ebuild b/media-video/bdsup2sub++/bdsup2sub++-1.0.2.ebuild
new file mode 100644
index 000000000000..de59e6869786
--- /dev/null
+++ b/media-video/bdsup2sub++/bdsup2sub++-1.0.2.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+inherit qmake-utils
+
+MY_PN="BDSup2SubPlusPlus"
+DESCRIPTION="C++ port of BDSup2Sub"
+HOMEPAGE="https://github.com/amichaelt/BDSup2SubPlusPlus"
+SRC_URI="https://github.com/amichaelt/${MY_PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ x11-libs/libqxt
+ dev-qt/qtcore:4
+ dev-qt/qtgui:4
+"
+DEPEND="${RDEPEND}"
+
+S="${WORKDIR}/${MY_PN}-${PV}/src"
+
+src_configure() {
+ eqmake4 ${PN}.pro
+}
+
+src_install() {
+ dobin ${PN}
+}