summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'media-video/ccextractor/ccextractor-0.85.ebuild')
-rw-r--r--media-video/ccextractor/ccextractor-0.85.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/media-video/ccextractor/ccextractor-0.85.ebuild b/media-video/ccextractor/ccextractor-0.85.ebuild
new file mode 100644
index 000000000000..ea26c55c5efa
--- /dev/null
+++ b/media-video/ccextractor/ccextractor-0.85.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+inherit eutils toolchain-funcs cmake-utils
+
+DESCRIPTION="Extract closed captioning subtitles from video to SRT"
+HOMEPAGE="http://ccextractor.sourceforge.net/"
+SRC_URI="mirror://sourceforge/ccextractor/${PN}-src-nowin.${PV}.zip"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="
+ media-libs/libpng:0=
+ sys-libs/zlib:=
+"
+DEPEND="${RDEPEND}
+ app-arch/unzip
+ virtual/pkgconfig"
+
+S="${WORKDIR}/${PN}/src"
+
+PATCHES=(
+ "${FILESDIR}/zlib.patch"
+ "${FILESDIR}/cflags.patch"
+)
+
+src_prepare() {
+ rm -rf libpng zlib || die
+ cmake-utils_src_prepare
+}