summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'media-video/gpac/gpac-9999.ebuild')
-rw-r--r--media-video/gpac/gpac-9999.ebuild21
1 files changed, 9 insertions, 12 deletions
diff --git a/media-video/gpac/gpac-9999.ebuild b/media-video/gpac/gpac-9999.ebuild
index 777f20e6208b..963ca68ca30f 100644
--- a/media-video/gpac/gpac-9999.ebuild
+++ b/media-video/gpac/gpac-9999.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2022 Gentoo Authors
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -40,7 +40,7 @@ RDEPEND="
virtual/opengl
)
png? ( media-libs/libpng:0= )
- pulseaudio? ( media-sound/pulseaudio )
+ pulseaudio? ( media-libs/libpulse )
theora? ( media-libs/libtheora )
truetype? ( media-libs/freetype:2 )
sdl? ( media-libs/libsdl )
@@ -63,8 +63,8 @@ DEPEND="
"
PATCHES=(
- "${FILESDIR}/${PN}-2.0.0-configure.patch"
- "${FILESDIR}/${PN}-1.0.0-zlib-compile.patch"
+ "${FILESDIR}/${PN}-2.2.0-configure.patch"
+ "${FILESDIR}/${PN}-2.2.0-ffmpeg6.patch"
)
DOCS=(
@@ -77,8 +77,6 @@ DOCS=(
README.md
)
-HTML_DOCS="share/doc/*.html"
-
my_use() {
local flag="$1" pflag="${2:-$1}"
if use ${flag}; then
@@ -90,7 +88,9 @@ my_use() {
src_prepare() {
default
- sed -i -e "s:\(--disable-.*\)=\*):\1):" configure || die
+
+ # TODO: remove when old zlib is no longer in tree
+ has_version "<sys-libs/zlib-1.3" && eapply "${FILESDIR}/${PN}-1.0.0-zlib-compile.patch"
}
src_configure() {
@@ -100,11 +100,8 @@ src_configure() {
--cc="$(tc-getCC)"
--libdir="$(get_libdir)"
--verbose
- --enable-ipv6
--enable-pic
--enable-svg
- --disable-amr
- --use-js=no
--use-ogg=system
$(use_enable alsa)
$(use_enable debug)
@@ -121,14 +118,14 @@ src_configure() {
$(use_enable X x11-xv)
$(my_use a52)
$(my_use aac faad)
- $(my_use dvb dvbx)
+ $(use_enable dvb dvbx)
$(my_use ffmpeg)
$(my_use jpeg)
$(my_use jpeg2k openjpeg)
$(my_use mad)
$(my_use png)
$(my_use theora)
- $(my_use truetype ft)
+ $(my_use truetype freetype)
$(my_use vorbis)
$(my_use xvid)
)