summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'media-video/super_demux/super_demux-0.3.ebuild')
-rw-r--r--media-video/super_demux/super_demux-0.3.ebuild16
1 files changed, 6 insertions, 10 deletions
diff --git a/media-video/super_demux/super_demux-0.3.ebuild b/media-video/super_demux/super_demux-0.3.ebuild
index 9e79e39bedcb..c033ffc41c50 100644
--- a/media-video/super_demux/super_demux-0.3.ebuild
+++ b/media-video/super_demux/super_demux-0.3.ebuild
@@ -1,11 +1,9 @@
-# Copyright 1999-2010 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-EAPI="2"
+EAPI=7
-inherit eutils toolchain-funcs flag-o-matic
-
-IUSE=""
+inherit flag-o-matic toolchain-funcs
DESCRIPTION="DVB transport stream TS to ES demultiplexer"
HOMEPAGE="http://panteltje.com/panteltje/dvd/"
@@ -15,13 +13,11 @@ LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64 ~x86"
-src_prepare() {
- epatch "${FILESDIR}/${P}.diff"
-}
+PATCHES=( "${FILESDIR}/${P}.diff" )
src_compile() {
- append-flags -D_FILE_OFFSET_BITS=64 -D_LARGEFILE_SOURCE -D_LARGEFILE64_SOURCE
- emake CC="$(tc-getCC)" CFLAGS="${CFLAGS}" || die "emake failed"
+ append-cflags -D_FILE_OFFSET_BITS=64 -D_LARGEFILE_SOURCE -D_LARGEFILE64_SOURCE
+ emake CC="$(tc-getCC)" CFLAGS="${CFLAGS}"
}
src_install() {