summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'media-video/vlc/vlc-3.0.9999.ebuild')
-rw-r--r--media-video/vlc/vlc-3.0.9999.ebuild40
1 files changed, 22 insertions, 18 deletions
diff --git a/media-video/vlc/vlc-3.0.9999.ebuild b/media-video/vlc/vlc-3.0.9999.ebuild
index ceca1a3dae1d..278eb623b4b6 100644
--- a/media-video/vlc/vlc-3.0.9999.ebuild
+++ b/media-video/vlc/vlc-3.0.9999.ebuild
@@ -1,4 +1,4 @@
-# Copyright 2000-2022 Gentoo Authors
+# Copyright 2000-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -20,7 +20,7 @@ else
else
SRC_URI="https://download.videolan.org/pub/videolan/testing/${MY_P}/${MY_P}.tar.xz"
fi
- KEYWORDS="~amd64 ~arm ~arm64 ~loong ~ppc ~ppc64 -sparc ~x86"
+ KEYWORDS="~amd64 ~arm ~arm64 ~loong ~ppc ~ppc64 ~riscv -sparc ~x86"
fi
inherit autotools flag-o-matic lua-single toolchain-funcs virtualx xdg
@@ -32,7 +32,7 @@ SLOT="0/5-9" # vlc - vlccore
IUSE="a52 alsa aom archive aribsub bidi bluray cddb chromaprint chromecast dav1d dbus
dc1394 debug directx dts +dvbpsi dvd +encode faad fdk +ffmpeg flac fluidsynth
- fontconfig +gcrypt gme gnome-keyring gstreamer +gui ieee1394 jack jpeg kate
+ fontconfig +gcrypt gme keyring gstreamer +gui ieee1394 jack jpeg kate
libass libcaca libnotify +libsamplerate libtar libtiger linsys lirc live lua
macosx-notifications mad matroska modplug mp3 mpeg mtp musepack ncurses nfs ogg
omxil optimisememory opus png projectm pulseaudio rdp run-as-root samba sdl-image
@@ -48,7 +48,7 @@ REQUIRED_USE="
libtar? ( skins )
libtiger? ( kate )
lua? ( ${LUA_REQUIRED_USE} )
- skins? ( gui truetype X xml )
+ skins? ( archive gui truetype X xml )
ssl? ( gcrypt )
vaapi? ( ffmpeg X )
vdpau? ( ffmpeg X )
@@ -58,12 +58,14 @@ BDEPEND="
virtual/pkgconfig
lua? ( ${LUA_DEPS} )
amd64? ( dev-lang/yasm )
+ wayland? ( dev-util/wayland-scanner )
x86? ( dev-lang/yasm )
"
+# <ffmpeg-5 dep for USE="ffmpeg vaapi" for bug #864721
RDEPEND="
media-libs/libvorbis
net-dns/libidn:=
- sys-libs/zlib[minizip]
+ sys-libs/zlib
virtual/libintl
virtual/opengl
a52? ( media-libs/a52dec )
@@ -110,7 +112,7 @@ RDEPEND="
dev-libs/libgpg-error
)
gme? ( media-libs/game-music-emu )
- gnome-keyring? ( app-crypt/libsecret )
+ keyring? ( app-crypt/libsecret )
gstreamer? ( >=media-libs/gst-plugins-base-1.4.5:1.0 )
gui? (
dev-qt/qtcore:5
@@ -153,7 +155,7 @@ RDEPEND="
media-libs/libmatroska:=
)
modplug? ( >=media-libs/libmodplug-0.8.9.0 )
- mp3? ( media-sound/mpg123 )
+ mp3? ( media-sound/mpg123-base )
mpeg? ( media-libs/libmpeg2 )
mtp? ( media-libs/libmtp:= )
musepack? ( media-sound/musepack-tools )
@@ -166,8 +168,8 @@ RDEPEND="
media-fonts/dejavu
>=media-libs/libprojectm-3.1.12:0=
)
- pulseaudio? ( media-sound/pulseaudio )
- rdp? ( >=net-misc/freerdp-2.0.0_rc0:=[client(+)] )
+ pulseaudio? ( media-libs/libpulse )
+ rdp? ( >=net-misc/freerdp-2.0.0_rc0:2=[client(+)] )
samba? ( >=net-fs/samba-4.0.0:0[client,-debug(-)] )
sdl-image? ( media-libs/sdl-image )
sftp? ( net-libs/libssh2 )
@@ -201,7 +203,10 @@ RDEPEND="
udev? ( virtual/udev )
upnp? ( net-libs/libupnp:=[ipv6(+)] )
v4l? ( media-libs/libv4l:= )
- vaapi? ( media-libs/libva:=[drm(+),wayland?,X?] )
+ vaapi? (
+ <media-video/ffmpeg-5
+ media-libs/libva:=[drm(+),wayland?,X?]
+ )
vdpau? ( x11-libs/libvdpau )
vnc? ( net-libs/libvncserver )
vpx? ( media-libs/libvpx:= )
@@ -230,6 +235,7 @@ PATCHES=(
"${FILESDIR}"/${PN}-2.2.8-freerdp-2.patch # bug 590164
"${FILESDIR}"/${PN}-3.0.6-fdk-aac-2.0.0.patch # bug 672290
"${FILESDIR}"/${PN}-3.0.11.1-configure_lua_version.patch
+ "${FILESDIR}"/${PN}-3.0.18-drop-minizip-dep.patch
)
DOCS=( AUTHORS THANKS NEWS README doc/fortunes.txt )
@@ -334,7 +340,7 @@ src_configure() {
$(use_enable fontconfig)
$(use_enable gcrypt libgcrypt)
$(use_enable gme)
- $(use_enable gnome-keyring secret)
+ $(use_enable keyring secret)
$(use_enable gstreamer gst-decode)
$(use_enable gui qt)
$(use_enable ieee1394 dv1394)
@@ -434,8 +440,12 @@ src_configure() {
)
# ^ We don't have these disabled libraries in the Portage tree yet.
+ # https://code.videolan.org/videolan/vlc/-/issues/17626 (bug #861143)
+ append-flags -fno-strict-aliasing
+ filter-lto
+
# Compatibility fix for Samba 4.
- use samba && append-cppflags "-I/usr/include/samba-4.0"
+ use samba && append-cppflags "-I${ESYSROOT}/usr/include/samba-4.0"
if use x86; then
# We need to disable -fstack-check if use >=gcc 4.8.0. bug #499996
@@ -444,12 +454,6 @@ src_configure() {
replace-flags -Os -O2
fi
- if use omxil; then
- # bug #723006
- # https://trac.videolan.org/vlc/ticket/24617
- append-cflags -fcommon
- fi
-
# FIXME: Needs libresid-builder from libsidplay:2 which is in another directory...
append-ldflags "-L${ESYSROOT}/usr/$(get_libdir)/sidplay/builders/"