summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'media-video/vlc/vlc-3.0.9999.ebuild')
-rw-r--r--media-video/vlc/vlc-3.0.9999.ebuild19
1 files changed, 13 insertions, 6 deletions
diff --git a/media-video/vlc/vlc-3.0.9999.ebuild b/media-video/vlc/vlc-3.0.9999.ebuild
index 793f7690453d..a42a129f841e 100644
--- a/media-video/vlc/vlc-3.0.9999.ebuild
+++ b/media-video/vlc/vlc-3.0.9999.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2018 Gentoo Authors
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -29,10 +29,10 @@ HOMEPAGE="https://www.videolan.org/vlc/"
LICENSE="LGPL-2.1 GPL-2"
SLOT="0/5-9" # vlc - vlccore
-IUSE="a52 alsa altivec aom archive aribsub bidi bluray cddb chromaprint chromecast dbus
- dc1394 debug directx dts +dvbpsi dvd +encode faad fdk +ffmpeg flac fluidsynth
- fontconfig +gcrypt gme gnome-keyring gstreamer ieee1394 jack jpeg kate libass
- libav libcaca libnotify +libsamplerate libtar libtiger linsys lirc live lua
+IUSE="10bit a52 alsa altivec aom archive aribsub bidi bluray cddb chromaprint chromecast
+ dav1d dbus dc1394 debug directx dts +dvbpsi dvd +encode faad fdk +ffmpeg flac
+ fluidsynth fontconfig +gcrypt gme gnome-keyring gstreamer ieee1394 jack jpeg kate
+ libass libav libcaca libnotify +libsamplerate libtar libtiger linsys lirc live lua
macosx-notifications macosx-qtkit mad matroska modplug mp3 mpeg mtp musepack ncurses
neon nfs ogg omxil opencv optimisememory opus png postproc projectm pulseaudio +qt5
rdp run-as-root samba sdl-image sftp shout sid skins soxr speex srt ssl
@@ -75,6 +75,7 @@ RDEPEND="
>=dev-libs/protobuf-2.5.0:=
>=net-libs/libmicrodns-0.0.9:=
)
+ dav1d? ( media-libs/dav1d )
dbus? ( sys-apps/dbus:0 )
dc1394? (
media-libs/libdc1394:2
@@ -211,7 +212,7 @@ RDEPEND="
x11-libs/xcb-util
x11-libs/xcb-util-keysyms
)
- x264? ( media-libs/x264:0= )
+ x264? ( >=media-libs/x264-0.0.20160712:0=[10bit?] )
x265? ( media-libs/x265:0= )
xml? ( dev-libs/libxml2:2 )
zeroconf? ( net-dns/avahi:0[dbus] )
@@ -418,6 +419,12 @@ src_configure() {
)
# ^ We don't have these disabled libraries in the Portage tree yet.
+ if use x264; then
+ myeconfargs+=( $(use_enable 10bit x26410b) )
+ else
+ myeconfargs+=( --disable-x26410b )
+ fi
+
# Compatibility fix for Samba 4.
use samba && append-cppflags "-I/usr/include/samba-4.0"