summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'media-video/vlc')
-rw-r--r--media-video/vlc/metadata.xml1
-rw-r--r--media-video/vlc/vlc-9999.ebuild6
2 files changed, 5 insertions, 2 deletions
diff --git a/media-video/vlc/metadata.xml b/media-video/vlc/metadata.xml
index 8442a26823a0..2780b9e075f7 100644
--- a/media-video/vlc/metadata.xml
+++ b/media-video/vlc/metadata.xml
@@ -30,6 +30,7 @@
<flag name="libtiger">Enable Ogg Kate subtitles rendering using libtiger</flag>
<flag name="linsys">Enable support for Linux Linear Systems Ltd. SDI and HD-SDI input cards</flag>
<flag name="live">Enable live555 streaming media support (client support for rtsp)</flag>
+ <flag name="loudness">Enable loudness normalisation according to the EBU R128 standard using <pkg>media-libs/libebur128</pkg></flag>
<flag name="lua">Enable Lua scripting support, needed for including support for Jamendo (online music platform) and similar things</flag>
<flag name="macosx-notifications">Enable Mac OS X notifications module (formerly growl)</flag>
<flag name="matroska">Enable matroska support using reference libraries (fallback on other existing matroska support if disabled, i.e., matroska enabled FFmpeg)</flag>
diff --git a/media-video/vlc/vlc-9999.ebuild b/media-video/vlc/vlc-9999.ebuild
index 66f5d75a5089..d042a82b703d 100644
--- a/media-video/vlc/vlc-9999.ebuild
+++ b/media-video/vlc/vlc-9999.ebuild
@@ -32,8 +32,8 @@ SLOT="0/12-9" # vlc - vlccore
IUSE="a52 alsa aom archive aribsub bidi bluray cddb chromaprint chromecast dav1d dbus
dc1394 debug directx dts +dvbpsi dvd +encode faad fdk +ffmpeg flac fluidsynth
fontconfig +gcrypt gme gnome-keyring gstreamer +gui ieee1394 jack jpeg kate kms
- libass libcaca libnotify libplacebo +libsamplerate libtar libtiger linsys lirc
- live lua macosx-notifications mad matroska modplug mp3 mpeg mtp musepack ncurses
+ libass libcaca libnotify libplacebo +libsamplerate libtar libtiger linsys lirc live
+ loudness lua macosx-notifications mad matroska modplug mp3 mpeg mtp musepack ncurses
nfs ogg omxil optimisememory opus png projectm pulseaudio rdp run-as-root samba
sdl-image sftp shout sid skins soxr speex srt ssl svg taglib theora tremor truetype
twolame udev upnp vaapi v4l vdpau vnc vorbis vpx wayland +X x264 x265 xml zeroconf
@@ -144,6 +144,7 @@ RDEPEND="
linsys? ( media-libs/zvbi )
lirc? ( app-misc/lirc )
live? ( media-plugins/live:= )
+ loudness? ( >=media-libs/libebur128-1.2.4:= )
lua? ( >=dev-lang/lua-5.1:0= )
mad? ( media-libs/libmad )
matroska? (
@@ -337,6 +338,7 @@ src_configure() {
$(use_enable linsys)
$(use_enable lirc)
$(use_enable live live555)
+ $(use_enable loudness ebur128)
$(use_enable lua)
$(use_enable macosx-notifications osx-notifications)
$(use_enable mad)