summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'media-video')
-rw-r--r--media-video/mpv/mpv-9999.ebuild6
1 files changed, 6 insertions, 0 deletions
diff --git a/media-video/mpv/mpv-9999.ebuild b/media-video/mpv/mpv-9999.ebuild
index 8e33c3e35e4a..7d21765d19a7 100644
--- a/media-video/mpv/mpv-9999.ebuild
+++ b/media-video/mpv/mpv-9999.ebuild
@@ -169,6 +169,12 @@ src_prepare() {
src_configure() {
tc-export CC PKG_CONFIG AR
+ if tc-is-cross-compiler && use raspberry-pi; then
+ export EXTRA_PKG_CONFIG_LIBDIR="${SYSROOT%/}${EPREFIX}/opt/vc/lib/pkgconfig"
+ # Drop next line when Gentoo bug 607344 is fixed or if you fixed it locally.
+ die "${PN} can't be cross built with raspberry-pi USE enabled. See Gentoo bug 607344."
+ fi
+
local mywafargs=(
--confdir="${EPREFIX}/etc/${PN}"
--docdir="${EPREFIX}/usr/share/doc/${PF}"