summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-analyzer/barnyard2')
-rw-r--r--net-analyzer/barnyard2/barnyard2-1.13.ebuild1
-rw-r--r--net-analyzer/barnyard2/files/barnyard2-1.13-odbc.patch41
2 files changed, 42 insertions, 0 deletions
diff --git a/net-analyzer/barnyard2/barnyard2-1.13.ebuild b/net-analyzer/barnyard2/barnyard2-1.13.ebuild
index 5068d965c0d2..7214129d7ec1 100644
--- a/net-analyzer/barnyard2/barnyard2-1.13.ebuild
+++ b/net-analyzer/barnyard2/barnyard2-1.13.ebuild
@@ -28,6 +28,7 @@ S="${WORKDIR}/${PN}-2-${PV}"
PATCHES=(
"${FILESDIR}"/${PN}-1.13-free.patch
"${FILESDIR}"/${PN}-1.13-libdir.patch
+ "${FILESDIR}"/${PN}-1.13-odbc.patch
"${FILESDIR}"/${PN}-1.13-pcap-1.9.0.patch
)
diff --git a/net-analyzer/barnyard2/files/barnyard2-1.13-odbc.patch b/net-analyzer/barnyard2/files/barnyard2-1.13-odbc.patch
new file mode 100644
index 000000000000..a7d77ee914fa
--- /dev/null
+++ b/net-analyzer/barnyard2/files/barnyard2-1.13-odbc.patch
@@ -0,0 +1,41 @@
+--- a/src/output-plugins/spo_database_cache.c
++++ b/src/output-plugins/spo_database_cache.c
+@@ -1202,10 +1202,10 @@
+
+
+
+-#if (defined(ENABLE_MYSQL) || defined(ENABLE_POSTGRESQL))
++#if (defined(ENABLE_MYSQL) || defined(ENABLE_POSTGRESQL) || defined(ENABLE_ODBC))
+ u_int32_t curr_row = 0;
+ u_int32_t queryColCount =0;
+-#endif /* (defined(ENABLE_MYSQL) || defined(ENABLE_POSTGRESQL)) */
++#endif /* (defined(ENABLE_MYSQL) || defined(ENABLE_POSTGRESQL) || defined(ENABLE_ODBC)) */
+
+
+ #ifdef ENABLE_ODBC
+--- a/src/output-plugins/spo_database.c
++++ b/src/output-plugins/spo_database.c
+@@ -3443,9 +3443,9 @@
+ #endif
+
+
+-#if defined(ENABLE_MYSQL) || defined(ENABLE_POSTGRESQL)
++#if defined(ENABLE_MYSQL) || defined(ENABLE_POSTGRESQL) || defined(ENABLE_ODBC)
+ int result = 0;
+-#endif /* defined(ENABLE_MYSQL) || defined(ENABLE_POSTGRESQL) */
++#endif /* defined(ENABLE_MYSQL) || defined(ENABLE_POSTGRESQL) || defined(ENABLE_ODBC) */
+
+
+ if( (query == NULL) ||
+@@ -3668,9 +3668,9 @@
+ int Select(char * query, DatabaseData * data,u_int32_t *rval)
+ {
+
+-#if defined(ENABLE_MYSQL) || defined(ENABLE_POSTGRESQL)
++#if defined(ENABLE_MYSQL) || defined(ENABLE_POSTGRESQL) || defined(ENABLE_ODBC)
+ int result = 0;
+-#endif /* defined(ENABLE_MYSQL) || defined(ENABLE_POSTGRESQL) */
++#endif /* defined(ENABLE_MYSQL) || defined(ENABLE_POSTGRESQL) || defined(ENABLE_ODBC) */
+
+ if( (query == NULL) ||
+ (data == NULL) ||