summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-analyzer/flowgrind/flowgrind-0.8.0-r1.ebuild')
-rw-r--r--net-analyzer/flowgrind/flowgrind-0.8.0-r1.ebuild49
1 files changed, 49 insertions, 0 deletions
diff --git a/net-analyzer/flowgrind/flowgrind-0.8.0-r1.ebuild b/net-analyzer/flowgrind/flowgrind-0.8.0-r1.ebuild
new file mode 100644
index 000000000000..2c2e1839abfa
--- /dev/null
+++ b/net-analyzer/flowgrind/flowgrind-0.8.0-r1.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="Network performance measurement tool"
+HOMEPAGE="http://flowgrind.net/ https://github.com/flowgrind/flowgrind/"
+SRC_URI="https://github.com/${PN}/${PN}/releases/download/${P}/${P}.tar.bz2"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug doc gsl pcap"
+
+RDEPEND="
+ dev-libs/xmlrpc-c[abyss,curl]
+ sys-apps/util-linux
+ gsl? ( sci-libs/gsl )
+ pcap? ( net-libs/libpcap )
+"
+DEPEND="
+ ${RDEPEND}
+"
+BDEPEND="
+ doc? ( app-doc/doxygen )
+"
+PATCHES=(
+ "${FILESDIR}"/${PN}-0.8.0-fno-common.patch
+)
+
+src_configure() {
+ econf \
+ $(use_enable debug) \
+ $(use_with doc doxygen) \
+ $(use_with gsl) \
+ $(use_with pcap)
+}
+
+src_compile() {
+ default
+
+ use doc && emake html
+}
+
+src_install() {
+ default
+
+ use doc && dodoc -r doc/html
+}