summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-analyzer/hexinject/files/hexinject-1.5-fix-build-system.patch')
-rw-r--r--net-analyzer/hexinject/files/hexinject-1.5-fix-build-system.patch15
1 files changed, 15 insertions, 0 deletions
diff --git a/net-analyzer/hexinject/files/hexinject-1.5-fix-build-system.patch b/net-analyzer/hexinject/files/hexinject-1.5-fix-build-system.patch
new file mode 100644
index 000000000000..046d083710df
--- /dev/null
+++ b/net-analyzer/hexinject/files/hexinject-1.5-fix-build-system.patch
@@ -0,0 +1,15 @@
+Respect user flags
+
+--- a/Makefile
++++ b/Makefile
+@@ -1,7 +1,7 @@
+ all:
+- gcc -o hexinject hexinject.c -lpcap
+- gcc -o prettypacket prettypacket.c
+- gcc -o hex2raw hex2raw.c
++ $(CC) $(CFLAGS) $(CPPFLAGS) $(LDFLAGS) -o hexinject hexinject.c -lpcap
++ $(CC) $(CFLAGS) $(CPPFLAGS) $(LDFLAGS) -o prettypacket prettypacket.c
++ $(CC) $(CFLAGS) $(CPPFLAGS) $(LDFLAGS) -o hex2raw hex2raw.c
+
+ clean:
+ rm -f hexinject prettypacket hex2raw *~