summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-analyzer/hexinject/hexinject-1.6.ebuild')
-rw-r--r--net-analyzer/hexinject/hexinject-1.6.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/net-analyzer/hexinject/hexinject-1.6.ebuild b/net-analyzer/hexinject/hexinject-1.6.ebuild
new file mode 100644
index 000000000000..5d8011ced352
--- /dev/null
+++ b/net-analyzer/hexinject/hexinject-1.6.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit flag-o-matic toolchain-funcs
+
+DESCRIPTION="Network packet sniffer and injector"
+HOMEPAGE="http://hexinject.sourceforge.net/"
+SRC_URI="http://downloads.sourceforge.net/project/${PN}/${P}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="+tools experimental"
+
+DEPEND="net-libs/libpcap"
+RDEPEND="${DEPEND}
+ experimental? ( dev-lang/tcl )"
+
+S="${WORKDIR}/${PN}"
+
+src_prepare() {
+ default
+ append-cflags -std=gnu89
+ tc-export CC
+}
+
+src_install() {
+ dobin hexinject
+ use tools && dobin hex2raw prettypacket
+ use experimental && dobin packets.tcl
+ einstalldocs
+}