summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-analyzer/hping/files')
-rw-r--r--net-analyzer/hping/files/bytesex.h.patch18
-rw-r--r--net-analyzer/hping/files/hping-3_pre20051105-ldflags.patch16
-rw-r--r--net-analyzer/hping/files/hping-3_pre20051105-libtcl.patch16
-rw-r--r--net-analyzer/hping/files/hping-3_pre20051105-scan-overflow.patch11
-rw-r--r--net-analyzer/hping/files/hping-3_pre20051105-tcl.patch11
-rw-r--r--net-analyzer/hping/files/hping-3_pre20051105-tclsh-proper-escaping.patch26
-rw-r--r--net-analyzer/hping/files/hping-3_pre20051105.patch45
7 files changed, 143 insertions, 0 deletions
diff --git a/net-analyzer/hping/files/bytesex.h.patch b/net-analyzer/hping/files/bytesex.h.patch
new file mode 100644
index 000000000000..872321d41bfd
--- /dev/null
+++ b/net-analyzer/hping/files/bytesex.h.patch
@@ -0,0 +1,18 @@
+--- a/bytesex.h
++++ b/bytesex.h
+@@ -9,11 +9,15 @@
+
+ #if defined(__i386__) \
+ || defined(__alpha__) \
++ || defined(__arm__) \
++ || defined(__x86_64__) \
++ || defined(__ia64__) \
+ || (defined(__mips__) && (defined(MIPSEL) || defined (__MIPSEL__)))
+ #define BYTE_ORDER_LITTLE_ENDIAN
+ #elif defined(__mc68000__) \
+ || defined (__sparc__) \
+ || defined (__sparc) \
++ || defined (__hppa__) \
+ || defined (__PPC__) \
+ || defined (__BIG_ENDIAN__) \
+ || (defined(__mips__) && (defined(MIPSEB) || defined (__MIPSEB__)))
diff --git a/net-analyzer/hping/files/hping-3_pre20051105-ldflags.patch b/net-analyzer/hping/files/hping-3_pre20051105-ldflags.patch
new file mode 100644
index 000000000000..39814bff0d8c
--- /dev/null
+++ b/net-analyzer/hping/files/hping-3_pre20051105-ldflags.patch
@@ -0,0 +1,16 @@
+--- a/Makefile.in
++++ b/Makefile.in
+@@ -50,11 +50,11 @@
+ $(RANLIB) $@
+
+ hping3: byteorder.h $(OBJ)
+- $(CC) -o hping3 $(CCOPT) $(DEBUG) $(OBJ) -L/usr/local/lib $(PCAP) @SOLARISLIB@ @TCL_LIB@
++ $(CC) -o hping3 $(CCOPT) $(LDFLAGS) $(DEBUG) $(OBJ) -L/usr/local/lib $(PCAP) @SOLARISLIB@ @TCL_LIB@
+ @echo
+
+ hping3-static: byteorder.h $(OBJ)
+- $(CC) -static -o hping3-static $(CCOPT) $(DEBUG) $(OBJ) -L/usr/local/lib $(PCAP) @SOLARISLIB@ @TCL_LIB@ -ldl
++ $(CC) -static -o hping3-static $(CCOPT) $(LDFLAGS) $(DEBUG) $(OBJ) -L/usr/local/lib $(PCAP) @SOLARISLIB@ @TCL_LIB@ -ldl
+
+ byteorder.h:
+ ./configure
diff --git a/net-analyzer/hping/files/hping-3_pre20051105-libtcl.patch b/net-analyzer/hping/files/hping-3_pre20051105-libtcl.patch
new file mode 100644
index 000000000000..807399cb553c
--- /dev/null
+++ b/net-analyzer/hping/files/hping-3_pre20051105-libtcl.patch
@@ -0,0 +1,16 @@
+When anything libtcl (bug #247282) this will fail, and we're only finding out
+the version of the library anyway, so why not use TCL_VER, which is found using
+a slightly less fishy method. -JeR
+
+--- a/configure
++++ b/configure
+@@ -98,8 +98,7 @@
+ fi
+ if [ -n $USE_TCL ]
+ then
+- LIBPOSTFIX=`ls -1 /usr/local/lib/ /usr/lib | grep 'libtcl[0-9]' | grep so | sed -e 's/\.so.*//g' -e 's/libtcl//g' | sort -r | head -1`
+- TCL_LIB="-ltcl${LIBPOSTFIX} -lm -lpthread"
++ TCL_LIB="-ltcl${TCL_VER} -lm -lpthread"
+ fi
+
+ #
diff --git a/net-analyzer/hping/files/hping-3_pre20051105-scan-overflow.patch b/net-analyzer/hping/files/hping-3_pre20051105-scan-overflow.patch
new file mode 100644
index 000000000000..2c3e01bf697a
--- /dev/null
+++ b/net-analyzer/hping/files/hping-3_pre20051105-scan-overflow.patch
@@ -0,0 +1,11 @@
+--- a/scan.c
++++ b/scan.c
+@@ -456,7 +456,7 @@
+ continue;
+ /* time to copy headers in a safe place */
+ p = packet+linkhdr_size+iphdrlen;
+- memcpy(&icmp, p, sizeof(subtcp));
++ memcpy(&icmp, p, sizeof(icmp));
+ p += sizeof(icmp);
+ memcpy(&subip, p, sizeof(ip));
+ p += sizeof(ip);
diff --git a/net-analyzer/hping/files/hping-3_pre20051105-tcl.patch b/net-analyzer/hping/files/hping-3_pre20051105-tcl.patch
new file mode 100644
index 000000000000..1fb734e349b4
--- /dev/null
+++ b/net-analyzer/hping/files/hping-3_pre20051105-tcl.patch
@@ -0,0 +1,11 @@
+--- a/configure
++++ b/configure
+@@ -63,7 +63,7 @@
+ #
+ for TCLPATH_TRY in "/usr/bin/" "/usr/local/bin/" "/bin/"
+ do
+- for TCLVER_TRY in "8.4" "8.3" "8.2" "8.1" "8.0"
++ for TCLVER_TRY in "8.6" "8.5" "8.4" "8.3" "8.2" "8.1" "8.0"
+ do
+ if [ -z $TCLSH ]
+ then
diff --git a/net-analyzer/hping/files/hping-3_pre20051105-tclsh-proper-escaping.patch b/net-analyzer/hping/files/hping-3_pre20051105-tclsh-proper-escaping.patch
new file mode 100644
index 000000000000..8cd7065c8393
--- /dev/null
+++ b/net-analyzer/hping/files/hping-3_pre20051105-tclsh-proper-escaping.patch
@@ -0,0 +1,26 @@
+Fix for https://bugs.gentoo.org/show_bug.cgi?id=486664
+
+--- a/configure
++++ b/configure
+@@ -65,10 +65,10 @@
+ do
+ for TCLVER_TRY in "8.6" "8.5" "8.4" "8.3" "8.2" "8.1" "8.0"
+ do
+- if [ -z $TCLSH ]
++ if [ -z "$TCLSH" ]
+ then
+ TCLSH_TRY=${TCLPATH_TRY}tclsh${TCLVER_TRY}
+- if [ -f $TCLSH_TRY ]
++ if [ -f "$TCLSH_TRY" ]
+ then
+ TCLSH=$TCLSH_TRY
+ echo "===> Found Tclsh in: $TCLSH"
+@@ -76,7 +76,7 @@
+ fi
+ done
+ done
+-if [ -f $TCLSH ]
++if [ -f "$TCLSH" ]
+ then
+ TCL_VER=`echo puts \\$tcl_version | $TCLSH -`
+ USE_TCL='-DUSE_TCL'
diff --git a/net-analyzer/hping/files/hping-3_pre20051105.patch b/net-analyzer/hping/files/hping-3_pre20051105.patch
new file mode 100644
index 000000000000..e3133f2b6b42
--- /dev/null
+++ b/net-analyzer/hping/files/hping-3_pre20051105.patch
@@ -0,0 +1,45 @@
+--- a/libpcap_stuff.c
++++ b/libpcap_stuff.c
+@@ -17,7 +17,7 @@
+ #include <stdlib.h>
+ #include <sys/ioctl.h>
+ #include <pcap.h>
+-#include <net/bpf.h>
++#include <pcap-bpf.h>
+
+ #include "globals.h"
+
+--- a/script.c
++++ b/script.c
+@@ -24,7 +24,7 @@
+
+ #include <sys/ioctl.h>
+ #include <pcap.h>
+-#include <net/bpf.h>
++#include <pcap-bpf.h>
+
+ #include "release.h"
+ #include "hping2.h"
+--- a/configure
++++ b/configure
+@@ -93,7 +93,7 @@
+ else
+ USE_TCL=""
+ TCL_LIB=""
+- echo "==> WARNING: no Tcl header files found!"
++ echo "==> WARNING: no Tcl header files found."
+ fi
+ fi
+ if [ -n $USE_TCL ]
+--- a/Makefile.in
++++ b/Makefile.in
+@@ -52,9 +52,6 @@
+ hping3: byteorder.h $(OBJ)
+ $(CC) -o hping3 $(CCOPT) $(DEBUG) $(OBJ) -L/usr/local/lib $(PCAP) @SOLARISLIB@ @TCL_LIB@
+ @echo
+- ./hping3 -v
+- @echo "use \`make strip' to strip hping3 binary"
+- @echo "use \`make install' to install hping3"
+
+ hping3-static: byteorder.h $(OBJ)
+ $(CC) -static -o hping3-static $(CCOPT) $(DEBUG) $(OBJ) -L/usr/local/lib $(PCAP) @SOLARISLIB@ @TCL_LIB@ -ldl