summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-analyzer/mk-livestatus/files/mk-livestatus-1.2.2_p3-no-strip.diff')
-rw-r--r--net-analyzer/mk-livestatus/files/mk-livestatus-1.2.2_p3-no-strip.diff23
1 files changed, 23 insertions, 0 deletions
diff --git a/net-analyzer/mk-livestatus/files/mk-livestatus-1.2.2_p3-no-strip.diff b/net-analyzer/mk-livestatus/files/mk-livestatus-1.2.2_p3-no-strip.diff
new file mode 100644
index 000000000000..a3f81a5054cb
--- /dev/null
+++ b/net-analyzer/mk-livestatus/files/mk-livestatus-1.2.2_p3-no-strip.diff
@@ -0,0 +1,23 @@
+--- src/Makefile.am 2013-08-20 14:24:46.000000000 +0200
++++ src/Makefile.am 2013-08-20 14:25:20.000000000 +0200
+@@ -54,9 +54,9 @@
+
+ livecheck$(EXEEXT): livecheck.c strutil.c check_icmp.c
+ if HAVE_DIET
+- diet -v $(CC) -Wno-deprecated-declarations $(CFLAGS) $(LDFLAGS) -I.. -s -o $@ $^
++ diet -v $(CC) -Wno-deprecated-declarations $(CFLAGS) $(LDFLAGS) -I.. -o $@ $^
+ else
+- $(CC) -x c -Wno-deprecated-declarations $(CFLAGS) $(LDFLAGS) -I.. -s -o $@ $^
++ $(CC) -x c -Wno-deprecated-declarations $(CFLAGS) $(LDFLAGS) -I.. -o $@ $^
+ endif
+
+ livestatus_so_CXXFLAGS = -I$(top_srcdir)/nagios -fPIC
+@@ -64,7 +64,7 @@
+
+ livestatus.o: $(livestatus_so_OBJECTS) $(livestatus_so_DEPENDENCIES)
+ -rm -f plugin.so
+- $(CXX) $(LDFLAGS) -s -fPIC -shared $(livestatus_so_OBJECTS) -o $@ -lpthread -lstdc++
++ $(CXX) $(LDFLAGS) -fPIC -shared $(livestatus_so_OBJECTS) -o $@ -lpthread -lstdc++
+
+ all-local: livestatus.o
+