summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-analyzer/mk-livestatus')
-rw-r--r--net-analyzer/mk-livestatus/Manifest1
-rw-r--r--net-analyzer/mk-livestatus/mk-livestatus-1.2.8_p16.ebuild157
2 files changed, 158 insertions, 0 deletions
diff --git a/net-analyzer/mk-livestatus/Manifest b/net-analyzer/mk-livestatus/Manifest
index 7a1c8c7e4e7e..bacc6eb7713b 100644
--- a/net-analyzer/mk-livestatus/Manifest
+++ b/net-analyzer/mk-livestatus/Manifest
@@ -1 +1,2 @@
DIST mk-livestatus-1.2.8p10.tar.gz 453496 SHA256 af21c393a17b783f8ca83ffe6e5eea884c74557c4f2bd8899720ced0b443b35e SHA512 ff25c2a8d0105fdd156bc922b56df10e3497361620671dc73242db0a7b57fbd34955b5f4fbd9954602c8011b1f6a5ebd4e278df7c3e66639d74110fd0035682d WHIRLPOOL c3354b04eac1eb8907eb781cdc785136ea4aac0c9d9a2e66d89291d4eeb89f3cd6efcfb2e554295140157b0d7099f1621cd4258e3cd7fa9c0459cd8c7c373d7e
+DIST mk-livestatus-1.2.8p16.tar.gz 453565 SHA256 db6ca46f9616d218103c441de8b72a7ae0a74836e65a85511bf60167625f8e95 SHA512 32d4bc014c008ac7afbdca53e6b3e0d71f8eee5f41f4a0299a8e14cee2a1ea93216fe04c4ff9aa7d7b927dde8e63d186f09a2847665851f1063e699cf73a8df4 WHIRLPOOL 1bb9fd21c78d8b9b1efa48204dbb9ed6676f7a43765e6e8c78cf62df182527b1d9ae589968b7d7c9075d30d6628e2c4eb95cfcaebbb0b6926821fc08510bfaec
diff --git a/net-analyzer/mk-livestatus/mk-livestatus-1.2.8_p16.ebuild b/net-analyzer/mk-livestatus/mk-livestatus-1.2.8_p16.ebuild
new file mode 100644
index 000000000000..2be3f2dd9d05
--- /dev/null
+++ b/net-analyzer/mk-livestatus/mk-livestatus-1.2.8_p16.ebuild
@@ -0,0 +1,157 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+GENTOO_DEPEND_ON_PERL=no
+PYTHON_COMPAT=( python2_7 )
+inherit autotools perl-module python-single-r1
+
+MY_PV="${PV/_p/p}"
+MY_P="${PN}-${MY_PV}"
+
+DESCRIPTION="Nagios/Icinga event broker that allows quick/direct access to your status data"
+HOMEPAGE="http://mathias-kettner.de/checkmk_livestatus.html"
+SRC_URI="http://mathias-kettner.de/download/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="examples nagios4 perl python test"
+
+RDEPEND="!sys-apps/ucspi-unix:0
+ perl? (
+ dev-lang/perl:0
+ virtual/perl-Digest-MD5:0
+ virtual/perl-Scalar-List-Utils:0
+ >=virtual/perl-Thread-Queue-2.11:0
+ virtual/perl-Encode:0
+ dev-perl/JSON-XS:0
+ )"
+DEPEND="${RDEPEND}
+ perl? (
+ dev-perl/Module-Install:0
+ virtual/perl-ExtUtils-MakeMaker:0
+ virtual/perl-File-Path:0
+ virtual/perl-File-Spec:0
+ virtual/perl-File-Temp:0
+ test? (
+ dev-perl/File-Copy-Recursive:0
+ dev-perl/Test-Pod:0
+ dev-perl/Test-Perl-Critic:0
+ dev-perl/Test-Pod-Coverage:0
+ dev-perl/Perl-Critic:0
+ dev-perl/Perl-Critic-Policy-Dynamic-NoIndirect:0
+ dev-perl/Perl-Critic-Deprecated:0
+ dev-perl/Perl-Critic-Nits:0
+ )
+ )"
+
+# For perl test
+SRC_TEST="parallel"
+
+S="${WORKDIR}/${MY_P}"
+
+PATCHES=(
+ "${FILESDIR}/1.2.8_p10-MEDIUM-Drop-default-strip.patch"
+ "${FILESDIR}/1.2.8_p10-MINOR-test-Remove-the-usage-of-Perl-Critic-Policy-Mo.patch"
+)
+
+src_prepare() {
+ default
+
+ # Use system Module::Install instead, it will be copied to $S by
+ # Module::install itself.
+ rm -rf api/perl/inc || die
+
+ if use perl; then
+ # Ensure patches are not applied twice
+ unset PATCHES
+ perl-module_src_prepare
+ fi
+
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ $(use_with nagios4)
+
+ if use perl; then
+ cd api/perl || die
+ perl-module_src_configure
+ fi
+}
+
+src_compile() {
+ emake
+
+ if use perl; then
+ cd api/perl || die
+ perl-module_src_compile
+ fi
+}
+
+src_test() {
+ if use perl; then
+ cd api/perl || die
+
+ export TEST_AUTHOR="Test Author"
+ perl-module_src_test
+ fi
+}
+
+src_install() {
+ emake install DESTDIR="${ED}"
+
+ # install a config file showing whats needed to enable livestatus for nagios
+ cat <<EOF >"${T}"/nagios.cfg
+# Ensure all data is set to event brokers
+event_broker_options=-1
+broker_module=${EPREFIX%/}/usr/$(get_libdir)/mk-livestatus/livestatus.o
+EOF
+ # same for icigna
+ cat <<EOF >"${T}"/icigna.cfg
+ cat << EOF > "${T}"/livestatus.cfg || die
+define module{
+ module_name mk-livestatus
+ module_type neb
+ path /usr/$(get_libdir)/mk-livestatus/livestatus.o
+ args /var/lib/icigna/rw/live
+ }
+EOF
+ insinto /usr/share/mk-livestatus
+ doins "${T}"/{nagios,icigna}.cfg
+
+ if use perl; then
+ cd api/perl || die
+ perl-module_src_install
+ cd "${S}"
+
+ if use examples; then
+ docinto /
+ newdoc api/perl/README README.perl
+
+ docinto examples
+ dodoc api/perl/examples/dump.pl
+ fi
+ fi
+
+ if use python; then
+ python_foreach_impl python_domodule api/python/livestatus.py
+
+ if use examples; then
+ docinto /
+ newdoc api/python/README README.python
+
+ docinto examples
+ dodoc api/python/{example,example_multisite,make_nagvis_map}.py
+ fi
+ fi
+}
+
+pkg_postinst() {
+ elog "Sample configurations for icigna and nagios are available in"
+ elog "/usr/share/${PN}"
+}