summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-analyzer/netdata/netdata-9999.ebuild')
-rw-r--r--net-analyzer/netdata/netdata-9999.ebuild9
1 files changed, 8 insertions, 1 deletions
diff --git a/net-analyzer/netdata/netdata-9999.ebuild b/net-analyzer/netdata/netdata-9999.ebuild
index 54d150969d3c..19ed4f693a0a 100644
--- a/net-analyzer/netdata/netdata-9999.ebuild
+++ b/net-analyzer/netdata/netdata-9999.ebuild
@@ -19,7 +19,7 @@ HOMEPAGE="https://github.com/netdata/netdata https://my-netdata.io/"
LICENSE="GPL-3+ MIT BSD"
SLOT="0"
-IUSE="caps +compression cpu_flags_x86_sse2 cups ipmi mysql nfacct nodejs postgres +python tor xen"
+IUSE="caps +compression cpu_flags_x86_sse2 cups dbengine ipmi mysql nfacct nodejs postgres +python tor xen"
REQUIRED_USE="
mysql? ( python )
python? ( ${PYTHON_REQUIRED_USE} )
@@ -41,6 +41,12 @@ RDEPEND="
virtual/awk
caps? ( sys-libs/libcap )
cups? ( net-print/cups )
+ dbengine? (
+ dev-libs/libuv
+ app-arch/lz4
+ dev-libs/judy
+ dev-libs/openssl:=
+ )
compression? ( sys-libs/zlib )
ipmi? ( sys-libs/freeipmi )
nfacct? (
@@ -91,6 +97,7 @@ src_configure() {
--localstatedir="${EPREFIX}"/var \
--with-user=${NETDATA_USER} \
$(use_enable cups plugin-cups) \
+ $(use_enable dbengine) \
$(use_enable nfacct plugin-nfacct) \
$(use_enable ipmi plugin-freeipmi) \
$(use_enable xen plugin-xenstat) \