summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-analyzer/nethogs/nethogs-0.8.0-r4.ebuild')
-rw-r--r--net-analyzer/nethogs/nethogs-0.8.0-r4.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/net-analyzer/nethogs/nethogs-0.8.0-r4.ebuild b/net-analyzer/nethogs/nethogs-0.8.0-r4.ebuild
new file mode 100644
index 000000000000..9356d4f1c57e
--- /dev/null
+++ b/net-analyzer/nethogs/nethogs-0.8.0-r4.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit eutils toolchain-funcs
+
+DESCRIPTION="A small 'net top' tool, grouping bandwidth by process"
+HOMEPAGE="http://nethogs.sf.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-1"
+SLOT="0"
+KEYWORDS="amd64 ~arm ~ia64 x86"
+
+RDEPEND="
+ net-libs/libpcap
+ sys-libs/ncurses
+"
+DEPEND="
+ ${RDEPEND}
+ virtual/pkgconfig
+"
+
+DOCS=( Changelog DESIGN README )
+
+S=${WORKDIR}/${PN}
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-gentoo.patch
+ tc-export CC CXX PKG_CONFIG
+}