summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-analyzer/nmap/files/nmap-6.49-no-FORTIFY_SOURCE.patch')
-rw-r--r--net-analyzer/nmap/files/nmap-6.49-no-FORTIFY_SOURCE.patch71
1 files changed, 71 insertions, 0 deletions
diff --git a/net-analyzer/nmap/files/nmap-6.49-no-FORTIFY_SOURCE.patch b/net-analyzer/nmap/files/nmap-6.49-no-FORTIFY_SOURCE.patch
new file mode 100644
index 000000000000..383975493be9
--- /dev/null
+++ b/net-analyzer/nmap/files/nmap-6.49-no-FORTIFY_SOURCE.patch
@@ -0,0 +1,71 @@
+--- a/Makefile.in
++++ b/Makefile.in
+@@ -41,7 +41,6 @@
+ # http://gcc.gnu.org/ml/gcc-patches/2004-09/msg02055.html
+ # Level 1 only makes changes that don't affect "conforming" programs,
+ # while level 2 enforces additional restrictions.
+-DEFS += -D_FORTIFY_SOURCE=2
+ # For mtrace debugging -- see MTRACE define in main.cc for instructions
+ # Should only be enabled during debugging and not in any real release.
+ # DEFS += -DMTRACE=1
+--- a/nsock/src/Makefile.in
++++ b/nsock/src/Makefile.in
+@@ -13,7 +13,6 @@
+ CCOPT =
+ DEFS = @DEFS@ -DNSOCK_VERSION=\"$(NSOCK_VERSION)\"
+ # With GCC, add extra security checks to source code.
+-DEFS += -D_FORTIFY_SOURCE=2
+ INCLS = -I../include
+ CFLAGS = @CFLAGS@ $(CCOPT)
+ # CFLAGS = -g -Wall $(DEFS) $(INCLS)
+--- a/nping/Makefile.in
++++ b/nping/Makefile.in
+@@ -38,7 +38,6 @@
+ # http://gcc.gnu.org/ml/gcc-patches/2004-09/msg02055.html
+ # Level 1 only makes changes that don't affect "conforming" programs,
+ # while level 2 enforces additional restrictions.
+-DEFS += -D_FORTIFY_SOURCE=2
+ # For mtrace debugging -- see MTRACE define in main.cc for instructions
+ # Should only be enabled during debugging and not in any real release.
+ # DEFS += -DMTRACE=1
+--- a/libnetutil/Makefile.in
++++ b/libnetutil/Makefile.in
+@@ -5,7 +5,6 @@
+ CXXFLAGS = @CXXFLAGS@
+ CPPFLAGS = @CPPFLAGS@ $(DEFS)
+ DEFS = @DEFS@
+-DEFS += -D_FORTIFY_SOURCE=2
+ AR = ar
+ RANLIB = @RANLIB@
+
+--- a/ncat/Makefile.in
++++ b/ncat/Makefile.in
+@@ -53,7 +53,6 @@
+ LIBS = @LIBS@
+ DEFS = @DEFS@ -DNCAT_DATADIR="\"$(pkgdatadir)\""
+ # With GCC, add extra security checks to source code.
+-DEFS += -D_FORTIFY_SOURCE=2
+ INCLS = -I. -I.. -I../nsock/include/ -I$(NBASEDIR)
+ RM = rm -f
+ STRIP = @STRIP@
+--- a/nbase/Makefile.in
++++ b/nbase/Makefile.in
+@@ -12,7 +12,6 @@
+ CCOPT =
+ DEFS = @DEFS@
+ # With GCC, add extra security checks to source code.
+-DEFS += -D_FORTIFY_SOURCE=2
+ CPPFLAGS = @CPPFLAGS@
+ CFLAGS = @CFLAGS@ $(CCOPT) $(GLIB_CFLAGS) $(DEFS) $(INCLS)
+ STATIC =
+--- a/nmap-update/Makefile.in
++++ b/nmap-update/Makefile.in
+@@ -11,7 +11,7 @@
+ CPPFLAGS = @CPPFLAGS@ $(DEFS) -I$(NBASEDIR)
+ LDFLAGS = @LDFLAGS@
+ LIBS = @LIBS@ $(NBASELIB)
+-DEFS = @DEFS@ -D_FORTIFY_SOURCE=2
++DEFS = @DEFS@
+ APR_LIBS = @APR_LIBS@
+ SVN_LIBS = @SVN_LIBS@
+