summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-analyzer/nttcp/nttcp-1.47-r3.ebuild')
-rw-r--r--net-analyzer/nttcp/nttcp-1.47-r3.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/net-analyzer/nttcp/nttcp-1.47-r3.ebuild b/net-analyzer/nttcp/nttcp-1.47-r3.ebuild
new file mode 100644
index 000000000000..906a90c352c7
--- /dev/null
+++ b/net-analyzer/nttcp/nttcp-1.47-r3.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit eutils toolchain-funcs
+
+DESCRIPTION="tool to test TCP and UDP throughput"
+HOMEPAGE="http://www.leo.org/~elmar/nttcp/"
+SRC_URI="http://www.leo.org/~elmar/nttcp/${P}.tar.gz"
+LICENSE="public-domain"
+
+SLOT="0"
+KEYWORDS="amd64 ~mips ~ppc x86"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-format-security.patch
+}
+
+src_compile() {
+ emake \
+ ARCH= \
+ CC="$(tc-getCC)" \
+ LFLAGS="${LDFLAGS}" \
+ OPT="${CFLAGS}"
+}
+
+src_install() {
+ dobin ${PN}
+ doman ${PN}.1
+}