summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-analyzer/pchar/files')
-rw-r--r--net-analyzer/pchar/files/pchar-1.5-snmp.patch24
1 files changed, 24 insertions, 0 deletions
diff --git a/net-analyzer/pchar/files/pchar-1.5-snmp.patch b/net-analyzer/pchar/files/pchar-1.5-snmp.patch
new file mode 100644
index 000000000000..9ebfbad39eb0
--- /dev/null
+++ b/net-analyzer/pchar/files/pchar-1.5-snmp.patch
@@ -0,0 +1,24 @@
+--- GetIfInfo.h.old 2005-02-12 21:32:18.000000000 +0100
++++ GetIfInfo.h 2006-09-22 11:08:44.000000000 +0200
+@@ -17,7 +17,7 @@
+ bool IsValid(void);
+
+ const char * GetDescription(void) const;
+- const char * GetIfInfo::GetName(void) const;
++ const char * GetName(void) const;
+ const char * GetContact(void) const;
+ const char * GetLocation(void) const;
+ const char * GetIfDescription(void) const;
+--- configure.in.old 2005-02-12 21:32:18.000000000 +0100
++++ configure.in 2006-10-24 23:08:38.000000000 +0200
+@@ -128,8 +128,8 @@
+ LDFLAGS="-L$with_snmp/lib $LDFLAGS"
+ CPPFLAGS="-I$with_snmp/include $CPPFLAGS"
+ fi
+- AC_CHECK_LIB(crypto, des_cbc_encrypt)
+- AC_CHECK_LIB(snmp, snmp_sess_init,,,-lcrypto)
++ AC_CHECK_LIB(crypto, DES_cbc_encrypt)
++ AC_CHECK_LIB(snmp, snmp_sess_init)
+ fi
+
+ dnl pcap support if desired. If the user enabled --with-pcap,