summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-analyzer/prometheus-uwsgi_exporter/prometheus-uwsgi_exporter-0.7.0.ebuild')
-rw-r--r--net-analyzer/prometheus-uwsgi_exporter/prometheus-uwsgi_exporter-0.7.0.ebuild54
1 files changed, 0 insertions, 54 deletions
diff --git a/net-analyzer/prometheus-uwsgi_exporter/prometheus-uwsgi_exporter-0.7.0.ebuild b/net-analyzer/prometheus-uwsgi_exporter/prometheus-uwsgi_exporter-0.7.0.ebuild
deleted file mode 100644
index 26946cce453c..000000000000
--- a/net-analyzer/prometheus-uwsgi_exporter/prometheus-uwsgi_exporter-0.7.0.ebuild
+++ /dev/null
@@ -1,54 +0,0 @@
-# Copyright 1999-2018 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-inherit user golang-build golang-vcs-snapshot systemd
-
-EGO_PN="github.com/timonwong/uwsgi_exporter"
-EGIT_COMMIT="v${PV/_rc/-rc.}"
-UWSGI_EXPORTER_COMMIT="20e35a9"
-ARCHIVE_URI="https://${EGO_PN}/archive/${EGIT_COMMIT}.tar.gz -> ${P}.tar.gz"
-KEYWORDS="~amd64"
-
-DESCRIPTION="uWSGI metrics exporter for prometheus.io"
-HOMEPAGE="https://github.com/timonwong/uwsgi_exporter"
-SRC_URI="${ARCHIVE_URI}"
-LICENSE="Apache-2.0"
-SLOT="0"
-IUSE=""
-
-DEPEND="dev-util/promu"
-
-pkg_setup() {
- enewgroup ${PN}
- enewuser ${PN} -1 -1 -1 ${PN}
-}
-
-src_prepare() {
- default
- sed -i -e "s/{{.Revision}}/${UWSGI_EXPORTER_COMMIT}/" src/${EGO_PN}/.promu.yml || die
-}
-
-src_compile() {
- pushd src/${EGO_PN} || die
- mkdir -p bin || die
- GOPATH="${S}" promu build -v --prefix uwsgi_exporter || die
- popd || die
-}
-
-src_install() {
- pushd src/${EGO_PN} || die
- dobin uwsgi_exporter/uwsgi_exporter
- dodoc README.md
- popd || die
- local dir
- for dir in /var/{lib,log}/${PN}; do
- keepdir "${dir}"
- fowners ${PN}:${PN} "${dir}"
- done
- newinitd "${FILESDIR}"/${PN}.initd ${PN}
- newconfd "${FILESDIR}"/${PN}.confd ${PN}
- insinto /etc/logrotate.d
- newins "${FILESDIR}/${PN}.logrotated" "${PN}"
- systemd_dounit "${FILESDIR}/${PN}.service"
-}