summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-analyzer/pypacker/pypacker-2.4.ebuild')
-rw-r--r--net-analyzer/pypacker/pypacker-2.4.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/net-analyzer/pypacker/pypacker-2.4.ebuild b/net-analyzer/pypacker/pypacker-2.4.ebuild
new file mode 100644
index 000000000000..8e652f6985e4
--- /dev/null
+++ b/net-analyzer/pypacker/pypacker-2.4.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python3_3 )
+
+inherit distutils-r1 vcs-snapshot
+
+DESCRIPTION="Fast and simple packet creation and parsing library for Python"
+HOMEPAGE="https://github.com/mike01/pypacker"
+SRC_URI="https://github.com/mike01/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="examples"
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+
+DOCS=( AUTHORS CHANGES HACKING README.md )
+
+python_test() {
+ "${PYTHON}" tests/test_pypacker.py || die
+}
+
+python_install_all() {
+ distutils-r1_python_install_all
+ use examples && dodoc -r examples
+}