summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-analyzer/snallygaster/snallygaster-0.0.9.ebuild')
-rw-r--r--net-analyzer/snallygaster/snallygaster-0.0.9.ebuild21
1 files changed, 21 insertions, 0 deletions
diff --git a/net-analyzer/snallygaster/snallygaster-0.0.9.ebuild b/net-analyzer/snallygaster/snallygaster-0.0.9.ebuild
new file mode 100644
index 000000000000..721aa4381322
--- /dev/null
+++ b/net-analyzer/snallygaster/snallygaster-0.0.9.ebuild
@@ -0,0 +1,21 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python3_{6,7,8} )
+DISTUTILS_SINGLE_IMPL=1
+inherit distutils-r1
+
+DESCRIPTION="Finds file leaks and other security problems on HTTP servers"
+HOMEPAGE="https://github.com/hannob/snallygaster"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="CC0-1.0"
+SLOT="0"
+KEYWORDS="~amd64"
+
+DEPEND="dev-python/dnspython
+ dev-python/urllib3
+ dev-python/beautifulsoup"
+RDEPEND="${DEPEND}"
+DOCS=( README.md TESTS.md )