summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-analyzer/snortsam/snortsam-2.70.ebuild')
-rw-r--r--net-analyzer/snortsam/snortsam-2.70.ebuild46
1 files changed, 46 insertions, 0 deletions
diff --git a/net-analyzer/snortsam/snortsam-2.70.ebuild b/net-analyzer/snortsam/snortsam-2.70.ebuild
new file mode 100644
index 000000000000..9e76045835b6
--- /dev/null
+++ b/net-analyzer/snortsam/snortsam-2.70.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit eutils flag-o-matic toolchain-funcs
+
+DESCRIPTION="Snort plugin that allows automated blocking of IP addresses on several firewalls"
+HOMEPAGE="http://www.snortsam.net/"
+SRC_URI="${HOMEPAGE}files/snortsam/${PN}-src-${PV}.tar.gz"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~alpha amd64 ppc ppc64 sparc x86"
+IUSE="debug"
+
+S=${WORKDIR}/${PN}
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-gentoo.patch
+ ecvs_clean
+}
+
+src_configure() {
+ use debug && append-cflags -DFWSAMDEBUG
+ tc-export CC
+}
+
+src_compile() {
+ sh makesnortsam.sh || die
+}
+
+src_install() {
+ dobin snortsam
+ find "${S}" -depth -type f -name "*.asc" -exec rm -f {} \;
+ dodoc docs/* conf/*
+}
+
+pkg_postinst() {
+ echo
+ elog "To use snortsam with snort, you'll have to compile snort with USE=snortsam."
+ elog "Read the INSTALL file to configure snort for snortsam, and configure"
+ elog "snortsam for your particular firewall."
+ echo
+}