summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-analyzer/wireshark/files/wireshark-2.6.0-androiddump-wsutil.patch')
-rw-r--r--net-analyzer/wireshark/files/wireshark-2.6.0-androiddump-wsutil.patch26
1 files changed, 26 insertions, 0 deletions
diff --git a/net-analyzer/wireshark/files/wireshark-2.6.0-androiddump-wsutil.patch b/net-analyzer/wireshark/files/wireshark-2.6.0-androiddump-wsutil.patch
new file mode 100644
index 000000000000..e28465e814a5
--- /dev/null
+++ b/net-analyzer/wireshark/files/wireshark-2.6.0-androiddump-wsutil.patch
@@ -0,0 +1,26 @@
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -2841,6 +2841,7 @@
+ if(HAVE_LIBPCAP)
+ set(androiddump_LIBS
+ ui
++ wsutil
+ ${GLIB2_LIBRARIES}
+ ${PCAP_LIBRARIES}
+ )
+@@ -2851,6 +2852,7 @@
+ set(androiddump_LIBS
+ ui
+ wiretap
++ wsutil
+ ${GLIB2_LIBRARIES}
+ ${ZLIB_LIBRARIES}
+ ${CMAKE_DL_LIBS}
+@@ -2862,7 +2864,6 @@
+ )
+
+ add_executable(androiddump WIN32 ${androiddump_FILES})
+- # XXX Shouldn't we add wsutil to androiddump_LIBS instead?
+ set_extcap_executable_properties(androiddump)
+ target_link_libraries(androiddump ${androiddump_LIBS})
+ install(TARGETS androiddump RUNTIME DESTINATION ${EXTCAP_DIR})