summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-analyzer')
-rw-r--r--net-analyzer/sslscan/sslscan-1.11.3-r1.ebuild27
-rw-r--r--net-analyzer/sslscan/sslscan-1.11.3.ebuild6
2 files changed, 30 insertions, 3 deletions
diff --git a/net-analyzer/sslscan/sslscan-1.11.3-r1.ebuild b/net-analyzer/sslscan/sslscan-1.11.3-r1.ebuild
new file mode 100644
index 000000000000..b44f1830c7a3
--- /dev/null
+++ b/net-analyzer/sslscan/sslscan-1.11.3-r1.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+inherit eutils toolchain-funcs
+
+DESCRIPTION="Fast SSL configuration scanner"
+HOMEPAGE="https://github.com/rbsec/sslscan"
+MY_FORK="rbsec"
+SRC_URI="https://github.com/${MY_FORK}/${PN}/archive/${PV}-${MY_FORK}.tar.gz -> ${P}-${MY_FORK}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="libressl"
+
+# Depend on -bindist since sslscan unconditionally requires elliptic
+# curve support, bug 491102
+DEPEND="!libressl? ( dev-libs/openssl:0[-bindist] ) libressl? ( dev-libs/libressl )"
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}/${P}-${MY_FORK}"
+src_install() {
+ DESTDIR="${D}" emake install
+}
diff --git a/net-analyzer/sslscan/sslscan-1.11.3.ebuild b/net-analyzer/sslscan/sslscan-1.11.3.ebuild
index b44f1830c7a3..a7cef35e02d6 100644
--- a/net-analyzer/sslscan/sslscan-1.11.3.ebuild
+++ b/net-analyzer/sslscan/sslscan-1.11.3.ebuild
@@ -13,12 +13,12 @@ SRC_URI="https://github.com/${MY_FORK}/${PN}/archive/${PV}-${MY_FORK}.tar.gz ->
LICENSE="GPL-3"
SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="libressl"
+KEYWORDS="amd64 x86"
+IUSE=""
# Depend on -bindist since sslscan unconditionally requires elliptic
# curve support, bug 491102
-DEPEND="!libressl? ( dev-libs/openssl:0[-bindist] ) libressl? ( dev-libs/libressl )"
+DEPEND="dev-libs/openssl:0[-bindist]"
RDEPEND="${DEPEND}"
S="${WORKDIR}/${P}-${MY_FORK}"