summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-dns/c-ares/c-ares-1.7.4.ebuild')
-rw-r--r--net-dns/c-ares/c-ares-1.7.4.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/net-dns/c-ares/c-ares-1.7.4.ebuild b/net-dns/c-ares/c-ares-1.7.4.ebuild
new file mode 100644
index 000000000000..a3745ad9cdea
--- /dev/null
+++ b/net-dns/c-ares/c-ares-1.7.4.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="2"
+
+DESCRIPTION="C library that resolves names asynchronously"
+HOMEPAGE="http://c-ares.haxx.se/"
+SRC_URI="http://${PN}.haxx.se/download/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="alpha amd64 arm hppa ia64 ~mips ppc ppc64 s390 sh sparc x86 ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~sparc64-solaris"
+IUSE=""
+
+DEPEND=""
+RDEPEND=""
+
+src_configure() {
+ econf --enable-shared --enable-nonblocking --enable-symbol-hiding \
+ --enable-warnings
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die
+ dodoc RELEASE-NOTES CHANGES NEWS README*
+}