summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-dns/ddclient')
-rw-r--r--net-dns/ddclient/Manifest3
-rw-r--r--net-dns/ddclient/ddclient-3.11.1.ebuild89
-rw-r--r--net-dns/ddclient/ddclient-3.11.2.ebuild89
-rw-r--r--net-dns/ddclient/ddclient-3.9.1-r2.ebuild67
-rw-r--r--net-dns/ddclient/files/ddclient-3.9.0-use_iproute2.patch29
-rw-r--r--net-dns/ddclient/files/ddclient.initd-r7 (renamed from net-dns/ddclient/files/ddclient.initd-r6)6
-rw-r--r--net-dns/ddclient/files/ddclient.service-r2 (renamed from net-dns/ddclient/files/ddclient.service-r1)2
-rw-r--r--net-dns/ddclient/files/ddclient.tmpfiles3
-rw-r--r--net-dns/ddclient/files/ddclient.tmpfiles-r13
-rw-r--r--net-dns/ddclient/metadata.xml5
10 files changed, 189 insertions, 107 deletions
diff --git a/net-dns/ddclient/Manifest b/net-dns/ddclient/Manifest
index 5de0f53b774b..73efc46f6784 100644
--- a/net-dns/ddclient/Manifest
+++ b/net-dns/ddclient/Manifest
@@ -1 +1,2 @@
-DIST ddclient-3.9.1.tar.gz 63469 BLAKE2B 8ae6543353d96f76d926117ae53d74da6e8bc8f116fa15b8b0d39bc29a4c334bfc3d673b8f1c57139213b91414d1b9a2063fde9e1015f03fb76ba70a60956a7e SHA512 a8a4d6cb94e4239a7b7b4fc7d9ebef703cbd6c45fc3394b644694a053b5b8aa8d109410b5b8b3676a5f30b18474d24c7feb16c65c30b28bd7d941d8a214b1346
+DIST ddclient-3.11.1.tar.gz 277452 BLAKE2B f496443b972cfed0623eae3a4056b4315cc085e3358189f0846bedaeda53912ec43949da5c4505cc749bf0dea247702e5c2415f06b27dc6549739833a39c8365 SHA512 e823ce54f94e268d62c52e2e13f32e5549b0f91721c876e0bfde2f948ac60d6346fb633b96eda410174c9f039c9c67034efdec7826f249f85c5890e33b3279b0
+DIST ddclient-3.11.2.tar.gz 278314 BLAKE2B 5e60d8ab0889fbfe03cf182faf025b84faa6a5c278d0c0c1fd45c0bab88828bc3ebacdadac44d1cbd71202f1eff79a7ae0ffcb668992ad54f71e36f8c2f74333 SHA512 b0d275f5ccc36cd8b532b6176de885696ff189dbdffa71bc63e9fa6db2aaf4ab5ff3290c251e318f05b2163c546dcc785eb3582388d9fb70e8439e35e5cbcd7f
diff --git a/net-dns/ddclient/ddclient-3.11.1.ebuild b/net-dns/ddclient/ddclient-3.11.1.ebuild
new file mode 100644
index 000000000000..cb205a5469cd
--- /dev/null
+++ b/net-dns/ddclient/ddclient-3.11.1.ebuild
@@ -0,0 +1,89 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit autotools optfeature systemd tmpfiles
+
+DESCRIPTION="Perl client used to update dynamic DNS entries"
+HOMEPAGE="https://ddclient.net/"
+SRC_URI="https://github.com/${PN}/${PN}/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
+
+KEYWORDS="~alpha amd64 arm arm64 ~hppa ~ia64 ~mips ppc ppc64 ~riscv ~sparc x86"
+LICENSE="GPL-2+"
+SLOT="0"
+IUSE="examples selinux test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ acct-group/ddclient
+ acct-user/ddclient
+ dev-lang/perl
+ net-misc/curl
+ dev-perl/Digest-SHA1
+ virtual/perl-Digest-SHA
+ virtual/perl-JSON-PP
+ selinux? ( sec-policy/selinux-ddclient )
+"
+
+BDEPEND="
+ test? (
+ dev-perl/HTTP-Daemon
+ dev-perl/HTTP-Daemon-SSL
+ dev-perl/Plack
+ dev-perl/Test-MockModule
+ dev-perl/Test-Warnings
+ )
+"
+
+src_prepare() {
+ default
+
+ # Remove PID setting, to reliably setup the environment for the init script
+ sed -e '/^pid/d' -i ddclient.conf.in || die
+
+ # Disable 'get_ip_from_if.pl' test, as it fails with network-sandbox
+ # Don't create cache directory, as it's created by init script / tmpfiles
+ sed -e '/get_ip_from_if.pl/d' -e '/MKDIR_P/d' -i Makefile.am || die
+
+ # Remove windows executable
+ if use examples; then
+ rm sample-etc_dhcpc_dhcpcd-eth0.exe || die
+ fi
+
+ eautoreconf
+}
+
+src_install() {
+ default
+
+ newinitd "${FILESDIR}"/ddclient.initd-r7 ddclient
+ systemd_newunit "${FILESDIR}"/ddclient.service-r2 ddclient.service
+ newtmpfiles "${FILESDIR}"/ddclient.tmpfiles-r1 ddclient.conf
+
+ if use examples; then
+ docinto examples
+ dodoc sample-*
+ fi
+
+ einstalldocs
+}
+
+pkg_postinst() {
+ if [[ ${REPLACING_VERSIONS} ]]; then
+ for v in ${REPLACING_VERSIONS}; do
+ if ver_test "${v}" -lt 3.10.0; then
+ if [ -f "${EROOT}/etc/ddclient/ddclient.conf" ]; then
+ cp /etc/ddclient/ddclient.conf /etc/ddclient.conf || die
+ ewarn "Your DDClient configuration has been copied from"
+ ewarn "'/etc/ddclient/ddclient.conf' to '/etc/ddclient.conf'."
+ ewarn "Please check your configuration."
+ fi
+ break
+ fi
+ done
+ fi
+
+ optfeature "using iproute2 instead if ifconfig." sys-apps/iproute2
+ tmpfiles_process ddclient.conf
+}
diff --git a/net-dns/ddclient/ddclient-3.11.2.ebuild b/net-dns/ddclient/ddclient-3.11.2.ebuild
new file mode 100644
index 000000000000..17f341073d57
--- /dev/null
+++ b/net-dns/ddclient/ddclient-3.11.2.ebuild
@@ -0,0 +1,89 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit autotools optfeature systemd tmpfiles
+
+DESCRIPTION="Perl client used to update dynamic DNS entries"
+HOMEPAGE="https://ddclient.net/"
+SRC_URI="https://github.com/${PN}/${PN}/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
+
+KEYWORDS="~alpha amd64 arm arm64 ~hppa ~ia64 ~mips ppc ppc64 ~riscv ~sparc x86"
+LICENSE="GPL-2+"
+SLOT="0"
+IUSE="examples selinux test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ acct-group/ddclient
+ acct-user/ddclient
+ dev-lang/perl
+ net-misc/curl
+ dev-perl/Digest-SHA1
+ virtual/perl-Digest-SHA
+ virtual/perl-JSON-PP
+ selinux? ( sec-policy/selinux-ddclient )
+"
+
+BDEPEND="
+ test? (
+ dev-perl/HTTP-Daemon
+ dev-perl/HTTP-Daemon-SSL
+ dev-perl/Plack
+ dev-perl/Test-MockModule
+ dev-perl/Test-Warnings
+ )
+"
+
+src_prepare() {
+ default
+
+ # Remove PID setting, to reliably setup the environment for the init script
+ sed -e '/^pid/d' -i ddclient.conf.in || die
+
+ # Disable 'get_ip_from_if.pl' test, as it fails with network-sandbox
+ # Don't create cache directory, as it's created by init script / tmpfiles
+ sed -e '/get_ip_from_if.pl/d' -e '/MKDIR_P/d' -i Makefile.am || die
+
+ # Remove windows executable
+ if use examples; then
+ rm sample-etc_dhcpc_dhcpcd-eth0.exe || die
+ fi
+
+ eautoreconf
+}
+
+src_install() {
+ default
+
+ newinitd "${FILESDIR}"/ddclient.initd-r7 ddclient
+ systemd_newunit "${FILESDIR}"/ddclient.service-r2 ddclient.service
+ newtmpfiles "${FILESDIR}"/ddclient.tmpfiles-r1 ddclient.conf
+
+ if use examples; then
+ docinto examples
+ dodoc sample-*
+ fi
+
+ einstalldocs
+}
+
+pkg_postinst() {
+ if [[ ${REPLACING_VERSIONS} ]]; then
+ for v in ${REPLACING_VERSIONS}; do
+ if ver_test "${v}" -lt 3.10.0; then
+ if [ -f "${EROOT}/etc/ddclient/ddclient.conf" ]; then
+ cp /etc/ddclient/ddclient.conf /etc/ddclient.conf || die
+ ewarn "Your DDClient configuration has been copied from"
+ ewarn "'/etc/ddclient/ddclient.conf' to '/etc/ddclient.conf'."
+ ewarn "Please check your configuration."
+ fi
+ break
+ fi
+ done
+ fi
+
+ optfeature "using iproute2 instead if ifconfig." sys-apps/iproute2
+ tmpfiles_process ddclient.conf
+}
diff --git a/net-dns/ddclient/ddclient-3.9.1-r2.ebuild b/net-dns/ddclient/ddclient-3.9.1-r2.ebuild
deleted file mode 100644
index b7461a66f5c5..000000000000
--- a/net-dns/ddclient/ddclient-3.9.1-r2.ebuild
+++ /dev/null
@@ -1,67 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-inherit systemd tmpfiles
-
-DESCRIPTION="Perl client used to update dynamic DNS entries"
-HOMEPAGE="https://ddclient.net/"
-SRC_URI="https://github.com/${PN}/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-
-KEYWORDS="~alpha amd64 arm arm64 ~hppa ~ia64 ~mips ppc ppc64 ~riscv ~sparc x86"
-LICENSE="GPL-2+"
-SLOT="0"
-IUSE="examples iproute2 selinux"
-
-RDEPEND="
- acct-group/ddclient
- acct-user/ddclient
- dev-lang/perl
- dev-perl/Data-Validate-IP
- dev-perl/Digest-SHA1
- dev-perl/IO-Socket-INET6
- dev-perl/IO-Socket-SSL
- virtual/perl-Digest-SHA
- virtual/perl-JSON-PP
- iproute2? ( sys-apps/iproute2 )
- selinux? ( sec-policy/selinux-ddclient )
-"
-
-src_prepare() {
- # Remove PID setting, to reliably setup the environment for the init script
- sed -e '/^pid/d' -i sample-etc_ddclient.conf || die
-
- # Remove windows executable
- if use examples; then
- rm sample-etc_dhcpc_dhcpcd-eth0.exe || die
- fi
-
- # Use sys-apps/iproute2 instead of sys-apps/net-tools
- use iproute2 && eapply "${FILESDIR}"/${PN}-3.9.0-use_iproute2.patch
-
- default
-}
-
-src_install() {
- dobin ddclient
-
- insinto /etc/ddclient
- insopts -m 0600 -o ddclient -g ddclient
- newins sample-etc_ddclient.conf ddclient.conf
-
- newinitd "${FILESDIR}"/ddclient.initd-r6 ddclient
- systemd_newunit "${FILESDIR}"/ddclient.service-r1 ddclient.service
- newtmpfiles "${FILESDIR}"/ddclient.tmpfiles ddclient.conf
-
- dodoc Change* README* RELEASENOTE TODO UPGRADE
-
- if use examples; then
- docinto examples
- dodoc sample-*
- fi
-}
-
-pkg_postinst() {
- tmpfiles_process ddclient.conf
-}
diff --git a/net-dns/ddclient/files/ddclient-3.9.0-use_iproute2.patch b/net-dns/ddclient/files/ddclient-3.9.0-use_iproute2.patch
deleted file mode 100644
index b57f78ba14e1..000000000000
--- a/net-dns/ddclient/files/ddclient-3.9.0-use_iproute2.patch
+++ /dev/null
@@ -1,29 +0,0 @@
---- a/ddclient 2018-08-09 17:58:16.000000000 +0200
-+++ b/ddclient 2018-09-01 22:35:43.000000000 +0200
-@@ -710,7 +710,7 @@
- [ "ip", "=s", "-ip address : set the IP address to 'address'" ],
- "",
- [ "if", "=s", "-if interface : obtain IP address from 'interface'" ],
-- [ "if-skip", "=s", "-if-skip pattern : skip any IP addresses before 'pattern' in the output of ifconfig {if}" ],
-+ [ "if-skip", "=s", "-if-skip pattern : skip any IP addresses before 'pattern' in the output of ip addr show {if}" ],
- "",
- [ "web", "=s", "-web provider|url : obtain IP address from provider's IP checking page" ],
- [ "web-skip", "=s", "-web-skip pattern : skip any IP addresses before 'pattern' on the web provider|url" ],
-@@ -1448,7 +1448,7 @@
-
- {
- local $opt{'use'} = 'if';
-- foreach my $if (grep {/^[a-zA-Z]/} `ifconfig -a`) {
-+ foreach my $if (grep {/^[a-zA-Z]/} `ip addr show`) {
- $if =~ s/:?\s.*//is;
- local $opt{'if'} = $if;
- printf "use=if, if=%s address is %s\n", opt('if'), define(get_ip('if'), 'NOT FOUND');
-@@ -2165,7 +2165,7 @@
-
- } elsif ($use eq 'if') {
- $skip = opt('if-skip', $h) || '';
-- $reply = `ifconfig $arg 2> /dev/null`;
-+ $reply = `ip addr show $arg 2> /dev/null`;
- $reply = `ip addr list dev $arg 2> /dev/null` if $?;
- $reply = '' if $?;
-
diff --git a/net-dns/ddclient/files/ddclient.initd-r6 b/net-dns/ddclient/files/ddclient.initd-r7
index 7bdc433d1ed1..62a6a9da6412 100644
--- a/net-dns/ddclient/files/ddclient.initd-r6
+++ b/net-dns/ddclient/files/ddclient.initd-r7
@@ -1,5 +1,5 @@
#!/sbin/openrc-run
-# Copyright 1999-2018 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
name="DDclient"
@@ -16,7 +16,7 @@ depend() {
}
start_pre() {
- checkpath -f -m 0600 -o ${command_user}:${command_group} /etc/ddclient/ddclient.conf
+ checkpath -f -m 0600 -o ${command_user}:${command_group} /etc/ddclient.conf
checkpath -d -m 0700 -o ${command_user}:${command_group} /run/ddclient
- checkpath -d -m 0700 -o ${command_user}:${command_group} /var/cache/ddclient
+ checkpath -d -m 0700 -o ${command_user}:${command_group} /var/lib/cache/ddclient
}
diff --git a/net-dns/ddclient/files/ddclient.service-r1 b/net-dns/ddclient/files/ddclient.service-r2
index d183b4f2a6c7..2ce4746a6ef2 100644
--- a/net-dns/ddclient/files/ddclient.service-r1
+++ b/net-dns/ddclient/files/ddclient.service-r2
@@ -1,6 +1,6 @@
[Unit]
After=network-online.target
-ConditionPathExists=/etc/ddclient/ddclient.conf
+ConditionPathExists=/etc/ddclient.conf
Description=DDclient
[Service]
diff --git a/net-dns/ddclient/files/ddclient.tmpfiles b/net-dns/ddclient/files/ddclient.tmpfiles
deleted file mode 100644
index 4c6cc19ab943..000000000000
--- a/net-dns/ddclient/files/ddclient.tmpfiles
+++ /dev/null
@@ -1,3 +0,0 @@
-z /etc/ddclient/ddclient.conf 0600 ddclient ddclient - -
-d /run/ddclient 0700 ddclient ddclient - -
-d /var/cache/ddclient 0700 ddclient ddclient - -
diff --git a/net-dns/ddclient/files/ddclient.tmpfiles-r1 b/net-dns/ddclient/files/ddclient.tmpfiles-r1
new file mode 100644
index 000000000000..eddef80e141e
--- /dev/null
+++ b/net-dns/ddclient/files/ddclient.tmpfiles-r1
@@ -0,0 +1,3 @@
+z /etc/ddclient.conf 0600 ddclient ddclient - -
+d /run/ddclient 0700 ddclient ddclient - -
+d /var/lib/cache/ddclient 0700 ddclient ddclient - -
diff --git a/net-dns/ddclient/metadata.xml b/net-dns/ddclient/metadata.xml
index 67bf4c73fbb9..211e2deb306b 100644
--- a/net-dns/ddclient/metadata.xml
+++ b/net-dns/ddclient/metadata.xml
@@ -17,10 +17,9 @@
</longdescription>
<use>
<flag name="examples">Install various example files, like for cron.</flag>
- <flag name="iproute2">Use <pkg>sys-apps/iproute2</pkg> instead of <pkg>sys-apps/net-tools</pkg> for interaction.</flag>
</use>
<upstream>
- <bugs-to>https://sourceforge.net/p/ddclient/bugs/</bugs-to>
- <remote-id type="sourceforge">ddclient</remote-id>
+ <bugs-to>https://github.com/ddclient/ddclient/issues</bugs-to>
+ <remote-id type="github">ddclient/ddclient</remote-id>
</upstream>
</pkgmetadata>