summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-dns/fpdns/fpdns-0.10.0_pre20130404-r1.ebuild')
-rw-r--r--net-dns/fpdns/fpdns-0.10.0_pre20130404-r1.ebuild19
1 files changed, 7 insertions, 12 deletions
diff --git a/net-dns/fpdns/fpdns-0.10.0_pre20130404-r1.ebuild b/net-dns/fpdns/fpdns-0.10.0_pre20130404-r1.ebuild
index 41acf92d3609..69910304830a 100644
--- a/net-dns/fpdns/fpdns-0.10.0_pre20130404-r1.ebuild
+++ b/net-dns/fpdns/fpdns-0.10.0_pre20130404-r1.ebuild
@@ -1,33 +1,28 @@
# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
+EAPI=8
-inherit epatch perl-module
+inherit perl-module
DESCRIPTION="Fingerprinting DNS servers"
HOMEPAGE="https://github.com/kirei/fpdns/"
-
MY_P="${PN}-${PV##*_pre}"
SRC_URI="https://github.com/kirei/fpdns/archive/20130404.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}"/"${MY_P}"
LICENSE="BSD"
SLOT="0"
KEYWORDS="~amd64 ~x86"
-IUSE=""
-DEPEND=""
RDEPEND=">=dev-perl/Net-DNS-0.74"
-S="${WORKDIR}"/"${MY_P}"
-
-src_prepare() {
- ## fixes https://github.com/kirei/fpdns/issues/6
- epatch "${FILESDIR}/${P}.ro-header.patch"
-}
+PATCHES=(
+ "${FILESDIR}"/${P}.ro-header.patch
+)
src_install() {
- newbin apps/fpdns fpdns
+ dobin apps/fpdns
insinto "${VENDOR_LIB}"/Net/DNS/
doins lib/Net/DNS/Fingerprint.pm
}