summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-dns/hash-slinger')
-rw-r--r--net-dns/hash-slinger/hash-slinger-2.6-r1.ebuild (renamed from net-dns/hash-slinger/hash-slinger-2.6.ebuild)11
-rw-r--r--net-dns/hash-slinger/metadata.xml6
2 files changed, 9 insertions, 8 deletions
diff --git a/net-dns/hash-slinger/hash-slinger-2.6.ebuild b/net-dns/hash-slinger/hash-slinger-2.6-r1.ebuild
index e3045b354142..8fb61bfb181d 100644
--- a/net-dns/hash-slinger/hash-slinger-2.6.ebuild
+++ b/net-dns/hash-slinger/hash-slinger-2.6-r1.ebuild
@@ -5,6 +5,7 @@
EAPI=5
PYTHON_COMPAT=( python2_7 )
+
inherit python-r1
DESCRIPTION="Various tools to generate special DNS records like SSHFP, TLSA, OPENPGPKEY, IPSECKEY"
@@ -16,26 +17,26 @@ SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE="ipsec +openpgp +ssh"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
DEPEND=""
RDEPEND="
${PYTHON_DEPS}
- dev-python/dnspython[$PYTHON_USEDEP]
dev-python/ipaddr[$PYTHON_USEDEP]
dev-python/m2crypto[$PYTHON_USEDEP]
net-dns/unbound[python,$PYTHON_USEDEP]
+ virtual/dnspython[$PYTHON_USEDEP]
ipsec? ( net-misc/libreswan[dnssec] )
openpgp? ( dev-python/python-gnupg[$PYTHON_USEDEP] )
ssh? ( net-misc/openssh )
"
-REQUIRED_USE="${PYTHON_REQUIRED_USE}"
-
src_install() {
local tools
tools="tlsa"
- use ssh && tools+=" sshfp"
+ use ssh && tools+=" sshfp"
use openpgp && tools+=" openpgpkey"
- use ipsec && tools+=" ipseckey"
+ use ipsec && tools+=" ipseckey"
for tool in $tools ; do
doman ${tool}.1
python_foreach_impl python_doscript ${tool}
diff --git a/net-dns/hash-slinger/metadata.xml b/net-dns/hash-slinger/metadata.xml
index 4b0698ebfd36..064d3c9a7032 100644
--- a/net-dns/hash-slinger/metadata.xml
+++ b/net-dns/hash-slinger/metadata.xml
@@ -6,8 +6,8 @@
<name>Marc Schiffbauer</name>
</maintainer>
<use>
- <flag name='ipsec'>Enable support for IPSECKEY records (ipseckey)</flag>
- <flag name='openpgp'>Enable support for OPENPGPKEY records (openpgpkey)</flag>
- <flag name='ssh'>Enable support for SSHFP records (sshfp)</flag>
+ <flag name="ipsec">Enable support for IPSECKEY records (ipseckey)</flag>
+ <flag name="openpgp">Enable support for OPENPGPKEY records (openpgpkey)</flag>
+ <flag name="ssh">Enable support for SSHFP records (sshfp)</flag>
</use>
</pkgmetadata>