summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-dns/updatedd/updatedd-2.6-r8.ebuild')
-rw-r--r--net-dns/updatedd/updatedd-2.6-r8.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/net-dns/updatedd/updatedd-2.6-r8.ebuild b/net-dns/updatedd/updatedd-2.6-r8.ebuild
new file mode 100644
index 000000000000..563946854844
--- /dev/null
+++ b/net-dns/updatedd/updatedd-2.6-r8.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit autotools
+
+DESCRIPTION="Dynamic DNS client with plugins for several dynamic dns services"
+HOMEPAGE="https://savannah.nongnu.org/projects/updatedd/"
+SRC_URI="https://savannah.nongnu.org/download/updatedd/${PN}_${PV}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ~arm ppc x86"
+
+RDEPEND="
+ dev-lang/perl
+ dev-perl/IO-Socket-Timeout
+"
+
+PATCHES=(
+ "${FILESDIR}/${P}-options.patch"
+ "${FILESDIR}/fix-ovh-DYNDNSHOST.patch"
+ "${FILESDIR}/set-socket-timeouts-for-ipserv.patch"
+ "${FILESDIR}/fix-ovh-support.patch"
+ "${FILESDIR}/${P}-respect-docdir.patch"
+)
+
+src_prepare() {
+ default
+
+ # Needed for Clang 16
+ eautoreconf
+}
+
+src_install() {
+ default
+
+ find "${ED}" -name '*.la' -delete || die
+}