summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-fs/netatalk/netatalk-3.1.8.ebuild')
-rw-r--r--net-fs/netatalk/netatalk-3.1.8.ebuild9
1 files changed, 2 insertions, 7 deletions
diff --git a/net-fs/netatalk/netatalk-3.1.8.ebuild b/net-fs/netatalk/netatalk-3.1.8.ebuild
index 41d2c5e84018..3416b1c570e0 100644
--- a/net-fs/netatalk/netatalk-3.1.8.ebuild
+++ b/net-fs/netatalk/netatalk-3.1.8.ebuild
@@ -75,18 +75,11 @@ src_configure() {
append-flags -fno-strict-aliasing
- if use acl; then
- myeconfargs+=( --with-acls $(use_with ldap) )
- else
- myeconfargs+=( --without-acls --without-ldap )
- fi
-
# Ignore --with-init-style=gentoo, we install the init.d by hand and we avoid having
# to sed the Makefiles to not do rc-update.
# TODO:
# systemd : --with-init-style=systemd
myeconfargs+=(
- --disable-silent-rules
$(use_enable avahi zeroconf)
$(use_enable debug)
$(use_enable debug debugging)
@@ -95,8 +88,10 @@ src_configure() {
$(use_enable kerberos krbV-uam)
$(use_enable quota)
$(use_enable tcpd tcp-wrappers)
+ $(use_with acl acls)
$(use_with cracklib)
$(use_with dbus afpstats)
+ $(use_with ldap)
$(use_with pam)
$(use_with samba smbsharemodes)
$(use_with shadow)