summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-im/telepathy-mission-control')
-rw-r--r--net-im/telepathy-mission-control/Manifest1
-rw-r--r--net-im/telepathy-mission-control/files/5.16.5-account-fix-property-name.patch25
-rw-r--r--net-im/telepathy-mission-control/telepathy-mission-control-5.16.5.ebuild48
3 files changed, 74 insertions, 0 deletions
diff --git a/net-im/telepathy-mission-control/Manifest b/net-im/telepathy-mission-control/Manifest
index d00bc4232b04..a0674cc3fc2f 100644
--- a/net-im/telepathy-mission-control/Manifest
+++ b/net-im/telepathy-mission-control/Manifest
@@ -1 +1,2 @@
DIST telepathy-mission-control-5.16.4.tar.gz 1102177 BLAKE2B 4c7ad46c472b6bc20b559de48602bcee971fda5ed2fb139d4a67793ac0f2871cfff6db5f9775a3626e1f1860fe41f8e4d520f00d05d7230064d30b21cb3397bc SHA512 5ed624df2d041554af074c22a18db2405fa5bd41bec40edc574382eb9d8b9f93ff6f4be3042d27f950694a353f4192670e200f5f8865419701ca520a973959ed
+DIST telepathy-mission-control-5.16.5.tar.gz 1125142 BLAKE2B 1f39336d8221ec9f297ba9eeaed39ffc30d5b2ecde3b02148343cfb9bf4ec15d949a36feb6b92cef17d70f786840b8df9cf159eb8eb00462c64bfb8b41437b57 SHA512 6adeb3033853bef5b732e7b85da49b75bffbdc57d968b1e4313fd1452eaf8db96c3f7f50d41ebb7bfcb084a7f093a9eaccdb28c23d2777e149a90dec6d4ef4e4
diff --git a/net-im/telepathy-mission-control/files/5.16.5-account-fix-property-name.patch b/net-im/telepathy-mission-control/files/5.16.5-account-fix-property-name.patch
new file mode 100644
index 000000000000..17eb7f1f0415
--- /dev/null
+++ b/net-im/telepathy-mission-control/files/5.16.5-account-fix-property-name.patch
@@ -0,0 +1,25 @@
+From d8dab08fe8db137c6bbd8bbdc3d9b01d98c48910 Mon Sep 17 00:00:00 2001
+From: =?UTF-8?q?Florian=20M=C3=BCllner?= <fmuellner@gnome.org>
+Date: Thu, 19 Dec 2019 13:37:49 +0100
+Subject: [PATCH] account: Fix property name
+
+Spaces are not valid characters in property names, and never were.
+Until recently GLib silently fixed up the name by replacing the
+space with '-', but now tightened up the validation.
+---
+ src/mcd-account.c | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/src/mcd-account.c b/src/mcd-account.c
+index 8009110e..de5c61cf 100644
+--- a/src/mcd-account.c
++++ b/src/mcd-account.c
+@@ -3442,7 +3442,7 @@ mcd_account_class_init (McdAccountClass * klass)
+
+ g_object_class_install_property
+ (object_class, PROP_CONNECTIVITY_MONITOR,
+- g_param_spec_object ("connectivity monitor",
++ g_param_spec_object ("connectivity-monitor",
+ "Connectivity monitor",
+ "Connectivity monitor",
+ MCD_TYPE_CONNECTIVITY_MONITOR,
diff --git a/net-im/telepathy-mission-control/telepathy-mission-control-5.16.5.ebuild b/net-im/telepathy-mission-control/telepathy-mission-control-5.16.5.ebuild
new file mode 100644
index 000000000000..9018152235cf
--- /dev/null
+++ b/net-im/telepathy-mission-control/telepathy-mission-control-5.16.5.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+GNOME2_LA_PUNT="yes"
+# Needed for tests and build #489466
+PYTHON_COMPAT=( python2_7 )
+
+inherit gnome2 python-any-r1
+
+DESCRIPTION="An account manager and channel dispatcher for the Telepathy framework"
+HOMEPAGE="https://cgit.freedesktop.org/telepathy/telepathy-mission-control/"
+SRC_URI="https://telepathy.freedesktop.org/releases/${PN}/${P}.tar.gz"
+
+LICENSE="LGPL-2.1+"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux"
+IUSE="debug networkmanager" # test
+
+RDEPEND="
+ >=dev-libs/dbus-glib-0.82
+ >=dev-libs/glib-2.46:2
+ >=sys-apps/dbus-0.95
+ >=net-libs/telepathy-glib-0.20
+ networkmanager? ( >=net-misc/networkmanager-1:= )
+"
+DEPEND="${RDEPEND}
+ ${PYTHON_DEPS}
+ dev-libs/libxslt
+ >=dev-util/gtk-doc-am-1.17
+ virtual/pkgconfig
+"
+# test? ( dev-python/twisted-words )"
+
+# Tests are broken, see upstream bug #29334 and #64212
+# upstream doesn't want it enabled everywhere (#29334#c12)
+RESTRICT="test"
+
+PATCHES=( "${FILESDIR}/5.16.5-account-fix-property-name.patch" )
+
+src_configure() {
+ # creds is not available
+ gnome2_src_configure \
+ --disable-static \
+ --disable-upower \
+ $(use_enable debug) \
+ $(use_with networkmanager connectivity nm)
+}